Bug 53142 - Installer hangs loading package information for kickstart-installation over nfs
Installer hangs loading package information for kickstart-installation over nfs
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-04 10:50 EDT by Patrick Hofmann
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 05:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message of anaconda (22.76 KB, patch)
2001-09-04 10:52 EDT, Patrick Hofmann
no flags Details | Diff

  None (edit)
Description Patrick Hofmann 2001-09-04 10:50:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [de] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Kickstart-installation over nfs stops when anaconda reads package
information out of the kickstart-file, only if Power-Tool-Packages are
listed in the kickstart file, e.g. like mpich or autorpm (otherwise the
installation is successful). 
The error message (see anaconda.txt): Cannot find these packages, even if I
had copied all Power-Tools packages like all packages of both binary CDs
with " cp -a /mnt/cdrom/RedHat /kickstart/cd-img-7.1 "to my nfs server
directory.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Using kickstart-file with package names of the Power Tools CD, e.g. mpich
2.Kickstart-Installation over NFS
3.
	

Actual Results:  Installation stops while anconda reading the package list
out of the kickstart-file with the message that packages (only those from
Power Tools) cannot be found

Expected Results:  Successful installation of the packages of the Power
Tools CD, e.g. mpich or autorpm, because they are in my NFS-directory

Additional info:
Comment 1 Patrick Hofmann 2001-09-04 10:52:14 EDT
Created attachment 30815 [details]
error message of anaconda
Comment 2 Jeremy Katz 2001-09-05 20:11:45 EDT
Did you use genhdlist after updating your comps file and adding the packages to
the RPMS directory?
Comment 3 Patrick Hofmann 2001-09-06 05:50:40 EDT
I only copied the files to my nfs directory.
Sorry, but ...
how can I update my comps file? Didn't find informations about this and cannot
find anything like genhdlist in order to create a new hdlist file....
Comment 4 Matt Wilson 2001-09-06 08:01:57 EDT
you must run genhdlist from the anaconda-runtime package to update the hdrlist.

Note You need to log in before you can comment on or make changes to this bug.