Bug 531431 - Font rendering is broken on Rawhide (radeon chipset)
Font rendering is broken on Rawhide (radeon chipset)
Status: CLOSED DUPLICATE of bug 529081
Product: Fedora
Classification: Fedora
Component: 0xFFFF (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-28 06:07 EDT by D.S. Ljungmark
Modified: 2009-11-04 08:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 16:04:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the problem (192.66 KB, image/png)
2009-10-28 06:07 EDT, D.S. Ljungmark
no flags Details
xorg log file (43.65 KB, text/plain)
2009-10-28 06:07 EDT, D.S. Ljungmark
no flags Details
lspci output (11.69 KB, text/plain)
2009-10-28 06:08 EDT, D.S. Ljungmark
no flags Details

  None (edit)
Description D.S. Ljungmark 2009-10-28 06:07:09 EDT
Created attachment 366409 [details]
Screenshot of the problem

Description of problem:
Fonts "disappear" in a cloud of pixels, mostly it's in certain fatness/fonts and it is reproducible, always the same letters.

Version-Release number of selected component (if applicable):
Rawhide, updated Wed 28, 2009
fontconfig-2.7.3-1.fc12.i686
cairo-1.8.8-3.fc12.i686
pango-1.26.0-1.fc12.i686
package xorg is not installed
xorg-x11-server-Xorg-1.7.0-1.fc12.i686
xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.i686
kernel-2.6.31.5-96.fc12.i686

How reproducible:
Always

Steps to Reproduce:
1.start x
2. start emacs
3. shudder at fonts
  
Actual results:
Broken letters in Firefox, Metacity, Emacs, gedit and other applications

Expected results:
Smooth and beautifully hinted fonts

Additional info:
Comment 1 D.S. Ljungmark 2009-10-28 06:07:47 EDT
Created attachment 366410 [details]
xorg log file
Comment 2 D.S. Ljungmark 2009-10-28 06:08:21 EDT
Created attachment 366411 [details]
lspci output
Comment 3 D.S. Ljungmark 2009-10-28 06:55:27 EDT
Fixed with the latest kernel (2.6.31.5-104.fc12) from :


http://koji.fedoraproject.org/koji/buildinfo?buildID=138707
Comment 4 D.S. Ljungmark 2009-10-28 08:56:11 EDT
Scratch the "Fixed" and replace it with "Greatly improved" I still see the same kind of error, but not in as many places. Currently on the B and F in bold text in metacity and a few other places.  Oh, and capital D in the bug reports and this text field.
Comment 5 Matthias Clasen 2009-10-28 11:08:04 EDT
Almost certainly a driver bug.
Comment 6 Jérôme Glisse 2009-10-28 16:04:00 EDT
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=529081

*** This bug has been marked as a duplicate of bug 529081 ***

Note You need to log in before you can comment on or make changes to this bug.