Bug 531453 - Resume and start problems in F12
Resume and start problems in F12
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-10-28 09:16 EDT by bobpoljakov
Modified: 2010-12-03 22:38 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-12-03 22:38:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Smolt profile (74 bytes, text/plain)
2009-10-28 09:16 EDT, bobpoljakov
no flags Details
pm-suspend.log (4.24 KB, application/octet-stream)
2009-10-28 09:18 EDT, bobpoljakov
no flags Details
biosdecode output (621 bytes, text/plain)
2010-02-23 05:30 EST, bobpoljakov
no flags Details

  None (edit)
Description bobpoljakov 2009-10-28 09:16:11 EDT
Created attachment 366427 [details]
Smolt profile

Description of problem:

After suspend, when i try to resume the computer, it turns on, shows blank screen for 2-3 seconds, then the computer turns off. After next try, it boots normally, but don't resume. Same situation after shutdown. Computer can boot only for second try. The problem exists with kernel-PAE-2.6.30.x but none with kernel-PAE-2.6.29.x kernels.

Version-Release number of selected component (if applicable):

How reproducible:
Always by suspend or shutdown.

Steps to Reproduce:
1.Suspend / shutdown
Actual results:
Can't boot for first try, which makes suspend/resume unusable.

Expected results:
Normal suspend/resume behavior.

Additional info:
Comment 1 bobpoljakov 2009-10-28 09:18:08 EDT
Created attachment 366428 [details]
Comment 2 Bruce Bigby 2009-11-02 21:36:04 EST
I have a similar resume-from-suspend problem on my System 76 (http://www.system76.com) pangolin laptop.  The symptom is that my system won't resume at all.  I press the power button to resume, but nothing happens.  I hold it down for a long while and eventually, the system performs a fresh boot -- not a resume.  On a good note, the resume-from-hibernate works. =)

In addition, although this is a different problem, my ability to disable the touch pad went away. I used to be able to select Fn-F1, but that doesn't work for this kernel.  It works for the previous one.

I also noticed at one point extraneous garbage characters entering my input stream while typing.  This prevented me from being able to switch users, because my password would always end up being incorrect.

With all that said, I'm very happy with the speed improvement. The system feels snappy/responsive like a system should feel.
Comment 3 Michael 2009-11-06 09:21:52 EST
Same problem here with a Sager NP9280: my system won't resume at all.  It was working perfectly up through, but suspend is broken in (don't know where the regression is).  I can provide whatever additional information you specify.
Comment 4 Michael 2009-11-06 22:03:43 EST
Just confirming that this bug DOES still exist in
Comment 5 Bruce Bigby 2009-11-06 22:16:41 EST
Ditto Comment #4.
Comment 6 bobpoljakov 2009-11-07 03:46:30 EST
Same problem here with the latest kernel. (
Comment 7 bobpoljakov 2009-11-21 09:27:25 EST
The problem still exist after update to fedora 12, with kernel
Comment 8 Michael 2009-11-21 12:38:03 EST
Then I can't upgrade to Fedora 12 because this is a show stopper.  Because of the nature of my work, I *must* be able to suspend the computer.
Comment 9 Bruce Bigby 2009-11-21 15:09:40 EST
Note: Hibernate appears to work, although the resume process takes longer, but at least you don't have to rebuild your session from scratch.
Comment 10 bobpoljakov 2009-11-26 11:00:19 EST
I've tried the kernel from updates testing ( Same problem.
Comment 11 Michael 2009-12-03 08:18:08 EST
Confirming that this bug does still exist in <sigh>
Comment 12 Leon Pollak 2009-12-04 15:27:33 EST
My MSI-1221 laptop with FC11 (updated) works brilliant under KDE, except that Ali web camera does not work and (more important!) it dos not resume after suspend.

It goes to sleep OK, but when I press the power button, it pulls the DVD and HD (1-2blinks) and goes back (to power down) in 3-4sec.

Then, after about 5-6s it repeats the attempt in exactly the same way for the second time - unsuccessfully.
And remains in this on-state: nothing works, except the power lamp and fan are on. Only the 10s power button pressing helps...
Comment 13 bobpoljakov 2009-12-10 16:39:56 EST
Updated to Suspend/resume still broken.
Comment 14 Bruce Bigby 2009-12-13 22:20:35 EST
I just upgraded to Fedora 12 (kernel and resume still doesn't work.  My hardware is a System76 pangolin laptop.
Comment 15 Rene 2009-12-21 18:27:17 EST
Have the same problem with and
Comment 16 Stephen Hatfield 2010-01-22 13:29:52 EST
Verifying that still exhibits the same non-functional issues with suspend/hibernate/resume.
Comment 17 bobpoljakov 2010-02-04 09:39:23 EST
I've installed the kernel (kernel-PAE- from updates-testing, resume still doesn't work.
Comment 18 bobpoljakov 2010-02-23 05:29:01 EST
I reinstalled my system, and switched from 32 to 64-bit. The problem still exists with the fresh install, with the latest stable kernel in F12.

After updating the kernel, I checked if resume is fixed. The symptoms was similar to earlier. After pressing space, laptop turns on, after 2 secs it turns off, then it is trying to start again, after 2 secs off again, then tries again, and do a simple boot. But, my bios settings changed after it. I had silent boot set off and boot password set, but after the failed resume test, theese changes were gone away.

I think it's a BIOS & a kernel problem. Any idea how to investigate, and fx this? Maybe I will try to update my BIOS, but it's not so funny without a floppy and a windows computer.

My laptop is an ACER Extensa 5620, BIOS version attached.
Comment 19 bobpoljakov 2010-02-23 05:30:09 EST
Created attachment 395684 [details]
biosdecode output
Comment 20 bobpoljakov 2010-02-23 05:37:10 EST
I forgot to mention, that after the failed resume, with the normal boot, after I logged in, networking was disabled. Maybe NetworkManager is affected by this problem.
Comment 21 Stephen Hatfield 2010-02-23 11:10:07 EST
Reporting that kernel  

still exhibits the same non-functional issues with suspend/hibernate/resume.
Comment 22 bobpoljakov 2010-03-07 12:11:14 EST
Still no change with
Comment 23 bobpoljakov 2010-03-09 10:24:07 EST
I mean kernel-; still no resume.
(.32 breaks my audio too; I've forgotten that I rebooted with the older kernel before uname -a)
Comment 24 Rene 2010-03-13 17:37:26 EST
While I disable the 55NetworkManager and 56dhclient hook (in /usr/lib/pm-utils/sleep.d) resume works. But the laptop will only fully wake up by pressing the space bar or the power button.

i disabled the 99hd-apm-restore.hook and i can fully wake up the laptop by pressing any key now.
Comment 25 Michael 2010-03-13 19:58:24 EST
I tried your suggestion, but unfortunately it didn't work for me.  However, by random chance I happened to disconnect my USB keyboard and then plug it in again. Voilà!  My computer woke up. 

Since this seems to be a problem where the laptops buttons (keyboard and power) are left in a state where they don't respond, somehow changing the devices on the USB bus wakes it up.  I suspect Bruce's problem is similar and may exhibit similar results.

At least now I have a workaround so I can wake from suspend.  Now if only I could get X11 to work in kernel 2.6.32...
Comment 26 bobpoljakov 2010-04-12 09:18:43 EDT
It seems that I've found the solution for my suspend/resume problem.
The solution is to add 'i8042.reset=1' kernel parameter to grub. It works for me.
I've found the solution in this thread: http://www.mail-archive.com/ubuntu-bugs@lists.ubuntu.com/msg2121923.html
Comment 27 Bug Zapper 2010-11-04 05:00:45 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 28 Bug Zapper 2010-12-03 22:38:52 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.