Bug 531529 - SELinux is preventing /usr/bin/xauth "write" access on .xauth22XesY.
SELinux is preventing /usr/bin/xauth "write" access on .xauth22XesY.
Status: CLOSED DUPLICATE of bug 531530
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:cad45820729...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-28 12:51 EDT by Jóhann B. Guðmundsson
Modified: 2013-01-10 00:33 EST (History)
42 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-28 13:13:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2009-10-28 12:51:42 EDT
Summary:

SELinux is preventing /usr/bin/xauth "write" access on .xauth22XesY.

Detailed Description:

SELinux denied access requested by xauth. It is not expected that this access is
required by xauth and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                .xauth22XesY [ file ]
Source                        xauth
Source Path                   /usr/bin/xauth
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-xauth-1.0.2-7.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-35.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.5-104.fc12.i686
                              #1 SMP Wed Oct 28 03:07:25 EDT 2009 i686 i686
Alert Count                   1
First Seen                    Wed 28 Oct 2009 04:46:27 PM GMT
Last Seen                     Wed 28 Oct 2009 04:46:27 PM GMT
Local ID                      1662e2f6-443c-4f80-bb15-4cc5404cc42a
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1256748387.616:21169): avc:  denied  { write } for  pid=1897 comm="xauth" name=".xauth22XesY" dev=dm-0 ino=5140 scontext=unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1256748387.616:21169): arch=40000003 syscall=33 success=no exit=-13 a0=bf85df27 a1=2 a2=bf85df27 a3=804e88c items=0 ppid=1890 pid=1897 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=1 comm="xauth" exe="/usr/bin/xauth" subj=unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-35.fc12,catchall,xauth,xauth_t,admin_home_t,file,write
audit2allow suggests:

#============= xauth_t ==============
allow xauth_t admin_home_t:file write;
Comment 1 Daniel Walsh 2009-10-28 13:13:51 EDT

*** This bug has been marked as a duplicate of bug 531530 ***

Note You need to log in before you can comment on or make changes to this bug.