This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 531581 - Encrypted autopart install on IBM Power5 ppc fails to find root device on boot
Encrypted autopart install on IBM Power5 ppc fails to find root device on boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-28 15:34 EDT by James Laska
Modified: 2013-09-02 02:41 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 16:35:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
boot.log (rdshell rdinitdebug) (13.55 KB, text/plain)
2009-10-28 15:34 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-10-28 15:34:21 EDT
Created attachment 366488 [details]
boot.log (rdshell rdinitdebug)

Description of problem:

After an encrypted autopart install on an IBM Power5 ppc system, the system fails to find the root volume on boot.  Adding 'rdshell' to the boot arguments does not result in a boot shell.  I'm able to rescue mode into the system and gather diagnostic information (see below).

Version-Release number of selected component (if applicable):

 * rawhide-20091028

How reproducible:

 * Seems every time now.  Boot works fine if I repeat the install without encrypted partitions.  Worked fine when tested during dracut test day.

Steps to Reproduce:

 * https://fedoraproject.org/wiki/QA:Testcase_Anaconda_autopart_(encrypted)_install
  
Actual results:

 * See attached boot logs

Expected results:

 * Passphrase prompt

Additional info:

# Kernel command line: root=/dev/mapper/vg_ibm505lp1-lv_root ro LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=hvc0 rhshell rdinitdebug  

# cat /etc/fstab
#
# /etc/fstab
# Created by anaconda on Wed Oct 28 14:26:26 2009
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/vg_ibm505lp1-lv_root /                       ext4    defaults        1 1
UUID=c2b460a1-889f-4ad1-a49b-3cbe4657ebd6 /boot                   ext4    defaults        1 2
/dev/mapper/vg_ibm505lp1-lv_swap swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0


# dmsetup ls --tree
vg_ibm505lp1-lv_swap (253:3)
 └─luks-eda7beb1-1f5e-40a8-a485-22a3c68497b5 (253:1)
    └─ (8:3)
vg_ibm505lp1-lv_root (253:2)
 ├─luks-eda7beb1-1f5e-40a8-a485-22a3c68497b5 (253:1)
 │  └─ (8:3)
 └─luks-dfa9625b-b95f-48af-9e3b-8d082078b5f5 (253:0)
    └─ (8:17)

# blkid -o udev
ID_FS_TYPE=squashfs
ID_FS_UUID=dfa9625b-b95f-48af-9e3b-8d082078b5f5
ID_FS_UUID_ENC=dfa9625b-b95f-48af-9e3b-8d082078b5f5
ID_FS_TYPE=crypto_LUKS
ID_FS_UUID=c2b460a1-889f-4ad1-a49b-3cbe4657ebd6
ID_FS_UUID_ENC=c2b460a1-889f-4ad1-a49b-3cbe4657ebd6
ID_FS_TYPE=ext4
ID_FS_UUID=eda7beb1-1f5e-40a8-a485-22a3c68497b5
ID_FS_UUID_ENC=eda7beb1-1f5e-40a8-a485-22a3c68497b5
ID_FS_TYPE=crypto_LUKS
ID_FS_UUID=1Y3bPr-SXsH-Zs77-rm7q-pkjr-XOKM-aixzIz
ID_FS_UUID_ENC=1Y3bPr-SXsH-Zs77-rm7q-pkjr-XOKM-aixzIz
ID_FS_TYPE=LVM2_member
ID_FS_UUID=7lFqU7-CHvd-6UVI-Tmow-R1Q3-aElz-gCs2vE
ID_FS_UUID_ENC=7lFqU7-CHvd-6UVI-Tmow-R1Q3-aElz-gCs2vE
ID_FS_TYPE=LVM2_member
ID_FS_UUID=55a9ae44-ea46-4c89-bb4e-00b249e35428
ID_FS_UUID_ENC=55a9ae44-ea46-4c89-bb4e-00b249e35428
ID_FS_TYPE=ext4
ID_FS_UUID=f73c56f0-82a5-4dc0-b512-276667165ee0
ID_FS_UUID_ENC=f73c56f0-82a5-4dc0-b512-276667165ee0
ID_FS_TYPE=swap

# blkid
/dev/loop0: TYPE="squashfs" 
/dev/sdb1: UUID="dfa9625b-b95f-48af-9e3b-8d082078b5f5" TYPE="crypto_LUKS" 
/dev/sda2: UUID="c2b460a1-889f-4ad1-a49b-3cbe4657ebd6" TYPE="ext4" 
/dev/sda3: UUID="eda7beb1-1f5e-40a8-a485-22a3c68497b5" TYPE="crypto_LUKS" 
/dev/mapper/luks-dfa9625b-b95f-48af-9e3b-8d082078b5f5: UUID="1Y3bPr-SXsH-Zs77-rm7q-pkjr-XOKM-aixzIz" TYPE="LVM2_member" 
/dev/mapper/luks-eda7beb1-1f5e-40a8-a485-22a3c68497b5: UUID="7lFqU7-CHvd-6UVI-Tmow-R1Q3-aElz-gCs2vE" TYPE="LVM2_member" 
/dev/mapper/vg_ibm505lp1-lv_root: UUID="55a9ae44-ea46-4c89-bb4e-00b249e35428" TYPE="ext4" 
/dev/mapper/vg_ibm505lp1-lv_swap: UUID="f73c56f0-82a5-4dc0-b512-276667165ee0" TYPE="swap" 

# find /dev/disk/  -not -type d
/dev/disk/by-uuid/f73c56f0-82a5-4dc0-b512-276667165ee0
/dev/disk/by-uuid/55a9ae44-ea46-4c89-bb4e-00b249e35428
/dev/disk/by-path/pci-0000:d0:01.0-scsi-0:1:5:0-part3
/dev/disk/by-path/pci-0000:d0:01.0-scsi-0:1:5:0-part2
/dev/disk/by-path/pci-0000:d0:01.0-scsi-0:1:8:0-part1
/dev/disk/by-path/pci-0000:d0:01.0-scsi-0:1:5:0-part1
/dev/disk/by-path/pci-0000:d0:01.0-scsi-0:1:8:0
/dev/disk/by-path/pci-0000:cc:01.0-scsi-0:0:0:0
/dev/disk/by-path/pci-0000:d0:01.0-scsi-0:1:5:0
/dev/disk/by-id/dm-uuid-LVM-5lOubZzN6gAVPVodlH3CeXSpmdXLHC6KDDeO1iIBfx9oYphSKxOYX3pamX7L6AAH
/dev/disk/by-id/dm-name-vg_ibm505lp1-lv_swap
/dev/disk/by-id/dm-uuid-LVM-5lOubZzN6gAVPVodlH3CeXSpmdXLHC6KO1gVerV02TI8tBqQSK2ZBxhKarbH2m8a
/dev/disk/by-id/dm-uuid-CRYPT-LUKS1-eda7beb11f5e40a8a48522a3c68497b5-luks-eda7beb1-1f5e-40a8-a485-22a3c68497b5
/dev/disk/by-id/dm-name-vg_ibm505lp1-lv_root
/dev/disk/by-id/dm-name-luks-eda7beb1-1f5e-40a8-a485-22a3c68497b5
/dev/disk/by-id/dm-uuid-CRYPT-LUKS1-dfa9625bb95f48af9e3b8d082078b5f5-luks-dfa9625b-b95f-48af-9e3b-8d082078b5f5
/dev/disk/by-id/dm-name-luks-dfa9625b-b95f-48af-9e3b-8d082078b5f5
/dev/disk/by-id/scsi-SIBM_H0ST336753LC_3HX3KMAA00007531N7XX-part3
/dev/disk/by-id/scsi-SIBM_H0ST336753LC_3HX3KMAA00007531N7XX-part2
/dev/disk/by-id/scsi-SIBM_H0ST336754LC_3KQ10W2K00007611ZBVR-part1
/dev/disk/by-id/scsi-SIBM_H0ST336753LC_3HX3KMAA00007531N7XX-part1
/dev/disk/by-id/scsi-SIBM_H0ST336754LC_3KQ10W2K00007611ZBVR
/dev/disk/by-id/scsi-SIBM_H0ST336753LC_3HX3KMAA00007531N7XX

# lvm pvdisplay
File descriptor 20 (/dev/tty3) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 21 (/sys/devices/pci0001:00/0001:00:01.0/net/eth0/address) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 22 (/sys/devices/pci0000:00/0000:00:02.0/0000:c0:01.0/net/eth1/address) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 23 (/sys/devices/pci0000:00/0000:00:02.0/0000:c0:01.1/net/eth2/address) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 24 (socket:[4055]) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 25 (socket:[4157]) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 26 (socket:[4162]) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 27 (socket:[4167]) leaked on lvm invocation. Parent PID 830: -bash
  --- Physical volume ---
  PV Name               /dev/dm-1
  VG Name               vg_ibm505lp1
  PV Size               33.70 GB / not usable 769.00 KB
  Allocatable           yes 
  PE Size (KByte)       4096
  Total PE              8626
  Free PE               4
  Allocated PE          8622
  PV UUID               7lFqU7-CHvd-6UVI-Tmow-R1Q3-aElz-gCs2vE
   
  --- Physical volume ---
  PV Name               /dev/dm-0
  VG Name               vg_ibm505lp1
  PV Size               33.90 GB / not usable 769.00 KB
  Allocatable           yes (but full)
  PE Size (KByte)       4096
  Total PE              8677
  Free PE               0
  Allocated PE          8677
  PV UUID               1Y3bPr-SXsH-Zs77-rm7q-pkjr-XOKM-aixzIz
   
# lvm vgdisplay
File descriptor 20 (/dev/tty3) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 21 (/sys/devices/pci0001:00/0001:00:01.0/net/eth0/address) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 22 (/sys/devices/pci0000:00/0000:00:02.0/0000:c0:01.0/net/eth1/address) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 23 (/sys/devices/pci0000:00/0000:00:02.0/0000:c0:01.1/net/eth2/address) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 24 (socket:[4055]) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 25 (socket:[4157]) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 26 (socket:[4162]) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 27 (socket:[4167]) leaked on lvm invocation. Parent PID 830: -bash
  --- Volume group ---
  VG Name               vg_ibm505lp1
  System ID             
  Format                lvm2
  Metadata Areas        2
  Metadata Sequence No  3
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                2
  Open LV               2
  Max PV                0
  Cur PV                2
  Act PV                2
  VG Size               67.59 GB
  PE Size               4.00 MB
  Total PE              17303
  Alloc PE / Size       17299 / 67.57 GB
  Free  PE / Size       4 / 16.00 MB
  VG UUID               5lOubZ-zN6g-AVPV-odlH-3CeX-Spmd-XLHC6K
   
# lvm lvdisplay
File descriptor 20 (/dev/tty3) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 21 (/sys/devices/pci0001:00/0001:00:01.0/net/eth0/address) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 22 (/sys/devices/pci0000:00/0000:00:02.0/0000:c0:01.0/net/eth1/address) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 23 (/sys/devices/pci0000:00/0000:00:02.0/0000:c0:01.1/net/eth2/address) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 24 (socket:[4055]) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 25 (socket:[4157]) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 26 (socket:[4162]) leaked on lvm invocation. Parent PID 830: -bash
File descriptor 27 (socket:[4167]) leaked on lvm invocation. Parent PID 830: -bash
  --- Logical volume ---
  LV Name                /dev/vg_ibm505lp1/lv_root
  VG Name                vg_ibm505lp1
  LV UUID                O1gVer-V02T-I8tB-qQSK-2ZBx-hKar-bH2m8a
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                61.82 GB
  Current LE             15827
  Segments               2
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:2
   
  --- Logical volume ---
  LV Name                /dev/vg_ibm505lp1/lv_swap
  VG Name                vg_ibm505lp1
  LV UUID                DDeO1i-IBfx-9oYp-hSKx-OYX3-pamX-7L6AAH
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                5.75 GB
  Current LE             1472
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:3
Comment 1 Harald Hoyer 2009-10-29 03:26:01 EDT
(In reply to comment #0)
> Created an attachment (id=366488) [details]
> boot.log (rdshell rdinitdebug)
> 
> Description of problem:
> 
> After an encrypted autopart install on an IBM Power5 ppc system, the system
> fails to find the root volume on boot.  Adding 'rdshell' to the boot arguments
> does not result in a boot shell.

No wonder.. you have a typo in your kernel command line:

Calling ibm,client-architecture...command line: root=/dev/mapper/vg_ibm505lp1-lv_root ro LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=hvc0 rhshell rdinitdebug 


s/rhshell/rdshell/g
Comment 2 Harald Hoyer 2009-10-29 03:26:48 EDT
and add "rdinfo"
Comment 3 Harald Hoyer 2009-10-29 03:28:19 EDT
does it work with root=UUID=55a9ae44-ea46-4c89-bb4e-00b249e35428 ??
Comment 4 Harald Hoyer 2009-10-29 03:29:40 EDT
dracut: dracut-002-13.4.git8f397a9b.fc12

Hmm, in rawhide there is a newer dracut, which can cope with kernels, which do not have "dm_mod" compiled in.
Comment 5 James Laska 2009-10-29 10:20:20 EDT
After discussing with Harald, it seems that dracut is doing things correctly, and plymouth may not be prompting for a passphrase to unlock the encrypted LVM PV's.

I have installed plymouth-0.8.0-0.2009.29.09.13.fc12 and rebuilt the initrd's, and the problem remains.  See boot log (http://pastie.org/674983).

Could there be further issues lurking with passphrase prompting on serial consoles (specifically console=hvc0)?  

Reassigning to plymouth.
Comment 6 James Laska 2009-10-29 15:23:39 EDT
After discussing with Ray, we both feel this block is worth considering as a blocker bug.

The impact is that encrypted installs on IBM ppc64 will not prompt for a passphrase on boot.  The workaround is to not use encrypted partitions.
Comment 7 James Laska 2009-10-30 13:03:36 EDT
Fix submitted as plymouth-0.8.0-0.2009.29.09.16.fc12 (http://koji.fedoraproject.org/koji/buildinfo?buildID=139083)
Comment 8 James Laska 2009-10-30 13:07:48 EDT
Installed updated plymouth-0.8.0-0.2009.29.09.16.fc12 packages, rebuilt initrd, and confirmed the problem is solved.

[ boot.log ]

ramdisk loaded at 03000000, size: 13302 Kbytes
OF stdout device is: /vdevice/vty@30000000
Preparing to boot Linux version 2.6.31.5-96.fc12.ppc64 (mockbuild@ppc10.fedora.phx.redhat.com) (gcc version 4.4.2 20091018 (Red Hat 4.4.2-4) (GCC) ) #1 SMP Fri Oct 23 19:17:43 EDT 2009
Calling ibm,client-architecture...command line: root=/dev/mapper/vg_ibm505lp1-lv_root ro  LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=hvc0 rhgb quiet 
memory layout at init:
  alloc_bottom : 0000000003cfe000
  alloc_top    : 0000000008000000
  alloc_top_hi : 00000000f5000000
  rmo_top      : 0000000008000000
  ram_top      : 00000000f5000000
instantiating rtas at 0x00000000076a1000... done
boot cpu hw idx 0000000000000000
starting cpu hw idx 0000000000000002... done
starting cpu hw idx 0000000000000004... done
starting cpu hw idx 0000000000000006... done
copying OF device tree...
Building dt strings...
Building dt structure...
Device tree strings 0x0000000003dff000 -> 0x0000000003e0032d
Device tree struct  0x0000000003e01000 -> 0x0000000003e14000
Calling quiesce...
returning from prom_init
Phyp-dump not supported on this hardware

/dev/sda3 is password protected:*********
Key slot 0 unlocked.
Buffer I/O error on device dm-1, logical block 64
Buffer I/O error on device dm-1, logical block 65
Buffer I/O error on device dm-1, logical block 66
Buffer I/O error on device dm-1, logical block 67
Buffer I/O error on device dm-1, logical block 68
Buffer I/O error on device dm-1, logical block 69
Buffer I/O error on device dm-1, logical block 70
Buffer I/O error on device dm-1, logical block 71
Buffer I/O error on device dm-1, logical block 72
Buffer I/O error on device dm-1, logical block 73
device-mapper: remove ioctl failed: Device or resource busy
Key slot 0 unlocked.
		Welcome to Fedora 
		Press 'I' to enter interactive startup.
Starting udev: qla3xxx QLogic ISP3XXX Network Driver
qla3xxx Driver name: qla3xxx, Version: v2.03.00-k5.
[  OK  ]
Setting hostname ibm-505-lp1.test.redhat.com:  [  OK  ]


...
Comment 9 James Laska 2009-10-31 12:11:56 EDT
Once the new plymouth is tagged ... this bug is already tested and can move to CLOSED RAWHIDE.

Track the tagging status at https://fedorahosted.org/rel-eng/ticket/2937

Note You need to log in before you can comment on or make changes to this bug.