Bug 531598 - X11 frozen after resume from suspend
X11 frozen after resume from suspend
Status: CLOSED DUPLICATE of bug 531825
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-28 16:54 EDT by cblaauw
Modified: 2009-11-05 04:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 04:01:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cblaauw 2009-10-28 16:54:54 EDT
After resuming a suspended machine, the screen shows light and dark grey stripes, but no desktop. Mouse is there.

After login from GDM mouse pointer is missing, VT swich restores mouse pointer.


Version-Release number of selected component (if applicable):

xorg-x11-drv-ati.i686                     6.13.0-0.10.20091006git457646d73.fc12

running on ati rv250

How reproducible:
Always

Steps to Reproduce:
1. Suspend machine to ram
2. Wake machine up
  
Actual results:
Screen shows garbage

Expected results:
Machine shows password window to unlock session

Additional info:
smolt info attached.
Comment 1 cblaauw 2009-10-28 17:20:55 EDT
Happens only with KMS, when booting with NOMODESET everything works, but appears to be much slower.

By the way, the screen is not turned off after specified time, but is only blanked out.
Comment 2 cblaauw 2009-10-29 15:42:00 EDT
changed component to kernel, I think it's not the driver.

Kernel version is 2.6.31.5-104.fc12.i686
Comment 3 cblaauw 2009-11-05 04:01:24 EST

*** This bug has been marked as a duplicate of bug 531825 ***

Note You need to log in before you can comment on or make changes to this bug.