This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 531629 - RuntimeError: Returning partitions to state prior to edit failed
RuntimeError: Returning partitions to state prior to edit failed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:6d8ab99f04d36b04f...
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-28 18:17 EDT by James Laska
Modified: 2013-09-02 02:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-13.37-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 20:10:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (240.65 KB, text/plain)
2010-03-09 08:52 EST, Søren Sandmann
no flags Details
Attached traceback automatically from anaconda. (268.75 KB, text/plain)
2010-03-24 12:32 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (115.34 KB, text/plain)
2010-03-29 04:26 EDT, Alexander Boström
no flags Details

  None (edit)
Description James Laska 2009-10-28 18:17:33 EDT
anaconda-12.39-1 failure (see anacdump.txt in attachment#366492 [details]) encountered on IBM Power5 system while testing autopart+shrink test.

= Steps to reproduce = 

1) First, do this -
https://fedoraproject.org/wiki/QA/TestCases/PartitioningExt4OnNativeDevice
2) After that install, do this -
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_autopart_%28shrink%29_install
3) There will be 2 'PPCPReP Boot' Partitions, I clicked "EDIT" on the original
partition and chose to format it again.  Click OK

= Actual results =

anaconda 12.39 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1148, in editPartition
    raise RuntimeError, ("Returning partitions to state "
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1084, in editCB
    self.editPartition(device)
RuntimeError: Returning partitions to state prior to edit failed

See attachment#366492 [details] for full traceback
Comment 1 Bug Zapper 2009-11-16 09:31:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 James Laska 2010-02-24 09:51:57 EST
Hitting this while testing F-13-Alpha-RC2 (specifically https://fedoraproject.org/wiki/QA:Testcase_Anaconda_ISCSI_No_Authentication).

The reproducer involved 

1. select all drives (local and iSCSI) for partitioning
2. At partition detail screen, I deleted all partitions from all drives
3. Select back
4. Select only local drives for install, and leave iSCSI as a data partition
5. At partition detail screen, click "Edit" on the "Free space" label under the iSCSI drive
6. Attempt to create a '/opt' partition on the iSCSI drive, traceback
Comment 3 Søren Sandmann 2010-03-09 08:52:54 EST
Created attachment 398794 [details]
Attached traceback automatically from anaconda.
Comment 4 James Laska 2010-03-24 12:32:48 EDT
Created attachment 402354 [details]
Attached traceback automatically from anaconda.
Comment 5 James Laska 2010-03-24 12:34:44 EDT
= Steps to Reproduce =

1. Install to a system with BIOS RAID
2. Add an iSCSI drive
3. Choose to autopartition 
4. Select only the local BIOS RAID drive for formatting
5. At partition detail screen, edit existing iSCSI partition (sdd1 I think).  Format it as ext4 '/iscsi'
Comment 6 Alexander Boström 2010-03-29 04:26:32 EDT
Created attachment 403222 [details]
Attached traceback automatically from anaconda.
Comment 7 Alexander Boström 2010-03-29 04:32:19 EDT
Another way to reproduce:

1. Do a default install (local disk not san/iscsi etc, replace existing linux system), but choose the option to review the layout.
2. Select /boot and try to change it to 1000 MB.

It will fail to expand /boot because there's no room and then the installer fails instead of reverting /boot to 500 MB.
Comment 8 Adam Williamson 2010-04-16 12:00:07 EDT
Discussed at today's blocker review meeting. We accept this as a blocker on the basis that it infringes "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above".

https://fedoraproject.org/wiki/Fedora_13_Final_Release_Criteria



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 David Lehman 2010-04-26 11:54:21 EDT
(In reply to comment #6)
> Created an attachment (id=403222) [details]
> Attached traceback automatically from anaconda.    

I was unable to reproduce using this procedure. My guess is that a partition alignment fix that went into anaconda-13.38-1 resolves your issue. Please try a newer anaconda and report the results if possible.
Comment 10 David Lehman 2010-04-26 11:55:50 EDT
(In reply to comment #4)
> Created an attachment (id=402354) [details]
> Attached traceback automatically from anaconda.    

This also looks like it will be resolved in anaconda-13.38-1. Please retest and report back with results if/when possible.
Comment 11 David Lehman 2010-04-26 12:13:16 EDT
The fix should actually be in anaconda-13.37-1 in case that makes testing easier for anyone.
Comment 12 James Laska 2010-04-30 12:36:41 EDT
Setting to MODIFIED based on comment#11
Comment 13 Adam Williamson 2010-05-03 20:10:55 EDT
tested TC1 using the reproduction scenario outlined in comment #7. could not reproduce. installer correctly showed a dialog saying there was no room to make /boot bigger, and then showed me the layout again, with /boot at 500MB. no traceback. if anyone else can still reproduce with TC1, please re-open.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.