This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 531686 - Callout list rendering issue
Callout list rendering issue
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
high Severity high
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-29 01:17 EDT by BenC
Modified: 2010-11-23 23:16 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.3-0.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-09 23:14:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
html example of issue (rendering problem) (36.77 KB, image/png)
2009-10-29 01:17 EDT, BenC
no flags Details
HTML example of fixed output (19.12 KB, image/png)
2009-11-25 17:40 EST, Jeff Fearn
no flags Details
PDF example of fixed output (43.91 KB, image/png)
2009-11-25 17:41 EST, Jeff Fearn
no flags Details

  None (edit)
Description BenC 2009-10-29 01:17:39 EDT
Created attachment 366553 [details]
html example of issue (rendering problem)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


h<programlistingco>
<areaspec>
<areaset id="ex.plco.const" coords="">
  <area id="ex.plco.c1" coords='4'/>
  <area id="ex.plco.c2" coords='8'/>
</areaset>
<area id="ex.plco.ret" coords='12'/>
<area id="ex.plco.dest" coords='12'/>
</areaspec>
<programlisting>
sub do_nothing_useful {
    my($a, $b, $c);

    $a = new A;
    
    $a->does_nothing_either();

    $b = new B; 

    $c = "frog";

    return ($a, $c);
}
</programlisting>
<calloutlist>
<callout arearefs="ex.plco.const">
<para>
These are calls to the constructor <function>new</function> in the object
classes.
</para>
</callout>
<callout arearefs="ex.plco.ret">
<para>
This function returns a two-element list.
</para>
</callout>
<callout arearefs="ex.plco.dest">
<para>
The <emphasis>destructor</emphasis> (<function>DESTROY</function>) for
the object <literal>$b</literal> will be called automatically for this
object since there can be no other references to it outside this function.
</para>
</callout>
</calloutlist>
</programlistingco>


Additional info:

The resultant html and pdf are unsightly and inconsistent. Large numbers in html and small numbers in the PDF.
Comment 1 Jeff Fearn 2009-11-24 18:18:50 EST
Clearly Ben is running an old publican because on publican 1.x you get:

No insertCallouts function is available.
 at /usr/lib/perl5/vendor_perl/5.8.8/Publican/Builder.pm line 738

Oopsy!

Need to implement this callout function similar to how the highlight function is done in Builder.pm.

Then make them pretty.

P.S. Rudi, is 1.x still going to happen for F11?
Comment 2 Jeff Fearn 2009-11-25 17:40:27 EST
Created attachment 373851 [details]
HTML example of fixed output
Comment 3 Jeff Fearn 2009-11-25 17:41:01 EST
Created attachment 373852 [details]
PDF example of fixed output
Comment 4 Jeff Fearn 2009-11-25 17:44:24 EST
Added insertCallouts xstl function. Fixed HTML & PDF layouts.
Comment 5 Fedora Update System 2009-12-07 21:14:24 EST
publican-1.3-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.3-0.fc12
Comment 6 Fedora Update System 2009-12-07 21:17:48 EST
publican-1.3-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.3-0.fc11
Comment 7 Fedora Update System 2009-12-09 23:13:24 EST
publican-1.3-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2009-12-09 23:26:16 EST
publican-1.3-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.