Bug 531691 - [All Lang][i18n] Body text of the composed mail is not appearing in the printed document
[All Lang][i18n] Body text of the composed mail is not appearing in the print...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: i18n
: 531716 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-29 03:16 EDT by Shankar Prasad
Modified: 2015-04-21 00:34 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-30 10:03:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 600132 None None None Never

  None (edit)
Description Shankar Prasad 2009-10-29 03:16:27 EDT
Description of problem:
In the evolution, body text of the composed mail is not appearing in the printed document

Version-Release number of selected component (if applicable):
evolution-2.28.0.2-fc12

How reproducible:


Steps to Reproduce:
1.Open evolution and start composing a mail
2.Switch kn locale, and input the text in Kannada(kn_IN)
3.Print composed mail
  
Actual results:
The body text is missing in printed document

Expected results:
The body text should appear in printed document

Additional info:
Comment 1 Milan Crha 2009-10-29 05:34:05 EDT
*** Bug 531716 has been marked as a duplicate of this bug. ***
Comment 2 A S Alam 2009-10-29 07:12:56 EDT
it is reproduced with Japanese/Hindi/Punjabi, so Changing...
Comment 3 Milan Crha 2009-10-29 07:48:31 EDT
I guess it does the same with File->Print Preview, does it? Could you attach a draft mail for testing, please? As when I try with cs_CZ letters, then it works fine in print preview.
Comment 4 Shankar Prasad 2009-10-29 08:06:04 EDT
With File -> Print Preview, it shows the text and by printing from there (using the printer icon ) will print the text properly.
Comment 5 Milan Crha 2009-10-29 08:48:49 EDT
(In reply to comment #4)
> With File -> Print Preview, it shows the text and by printing from there (using
> the printer icon ) will print the text properly.  

Could you check whether printing of some similar text from, say, gedit is working properly, please?
Comment 6 Runa Bhattacharjee 2009-10-29 08:54:56 EDT
I just checked with gedit and firefox, and prints from both: File=>Print and File=>Print Preview=>Print work as expected.

Additionally, for the current problem:

In case of File=>Print Preview=>Print, the user is not being prompted to select the print location and a new version of output.pdf is being generated. Is this a feature that is being controlled by any configuration settings?

hth
Thanks
Comment 7 Matthew Barnes 2009-10-29 09:18:14 EDT
The print and print preview windows are outside of Evolution's control.
Those windows are managed directly by GTK+.
Comment 8 Milan Crha 2009-10-30 10:03:57 EDT
Good, I was able to reproduce it finally. The issue is on 2.28, but not on 2.29. I'm moving this upstream [1], as it's not Fedora specific issue. Thanks for finding this.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=600132

Note You need to log in before you can comment on or make changes to this bug.