Bug 531696 - ibus-anthy KeyError is still reported by abrt
Summary: ibus-anthy KeyError is still reported by abrt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-anthy
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1d206263
: 542142 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-29 08:31 UTC by Ví­ctor Daniel
Modified: 2010-05-04 06:56 UTC (History)
11 users (show)

Fixed In Version: 1.2.0.20091127-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-16 01:21:20 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (785 bytes, text/plain)
2009-10-29 08:31 UTC, Ví­ctor Daniel
no flags Details
Patch for ibus-anthy/engine/engine.py (995 bytes, patch)
2009-11-24 06:19 UTC, fujiwara
no flags Details | Diff

Description Ví­ctor Daniel 2009-10-29 08:31:03 UTC
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----


Additional information
======


Attached files
----
backtrace

cmdline
-----
python /usr/share/ibus-anthy/engine/main.py --ibus 


component
-----
ibus-anthy


executable
-----
/usr/share/ibus-anthy/engine/main.py


kernel
-----
2.6.31.5-96.fc12.i686


package
-----
ibus-anthy-1.2.0.20090917-2.fc12


uuid
-----
1d206263

Comment 1 Ví­ctor Daniel 2009-10-29 08:31:06 UTC
Created attachment 366570 [details]
File: backtrace

Comment 2 fujiwara 2009-10-30 02:23:43 UTC
I fixed "panel" property a few days ago.
However in this bug, ibus parent sends "general" and it's a too general word.

Probably it's better for the ibus parent to send another word, e.g. "ibus-frame".
Then ibus-anthy can ignore the property.

This could be reproduced when you change "Use system keyboard".

Comment 3 Bug Zapper 2009-11-16 14:33:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 fujiwara 2009-11-24 05:14:38 UTC
Talking ibus maintainer with bug 540773, other engines have used "engine/$engine".
ibus-anthy also could follow the way to fix this bug.

Comment 5 fujiwara 2009-11-24 06:19:06 UTC
Created attachment 373347 [details]
Patch for ibus-anthy/engine/engine.py

It seems ibus-anthy has already configure "engine/anthy/common".

Comment 7 Fedora Update System 2009-11-27 07:51:58 UTC
ibus-anthy-1.2.0.20091127-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ibus-anthy-1.2.0.20091127-1.fc12

Comment 8 Fedora Update System 2009-11-27 21:57:19 UTC
ibus-anthy-1.2.0.20091127-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-anthy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12280

Comment 9 fujiwara 2009-11-30 02:42:16 UTC
*** Bug 542142 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2009-12-16 01:21:14 UTC
ibus-anthy-1.2.0.20091127-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.