Bug 531699 - SELinux is preventing /usr/bin/xauth "unlink" access on .xauthBy6t6d.
SELinux is preventing /usr/bin/xauth "unlink" access on .xauthBy6t6d.
Status: CLOSED DUPLICATE of bug 531530
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:6ae96d6634c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-29 04:34 EDT by Michal Hlavinka
Modified: 2009-10-30 10:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-29 09:20:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2009-10-29 04:34:47 EDT
Summary:

SELinux is preventing /usr/bin/xauth "unlink" access on .xauthBy6t6d.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by xauth. It is not expected that this access is
required by xauth and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                .xauthBy6t6d [ file ]
Source                        xauth
Source Path                   /usr/bin/xauth
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-xauth-1.0.2-7.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-35.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.5-104.fc12.x86_64 #1
                              SMP Wed Oct 28 02:36:14 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Thu 29 Oct 2009 09:33:16 AM CET
Last Seen                     Thu 29 Oct 2009 09:33:16 AM CET
Local ID                      ed044a62-6448-44aa-80cc-b9bb19620a0a
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1256805196.79:97): avc:  denied  { unlink } for  pid=2465 comm="xauth" name=".xauthBy6t6d" dev=dm-1 ino=5011 scontext=unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1256805196.79:97): arch=c000003e syscall=87 success=yes exit=0 a0=a9a010 a1=389cf7be80 a2=ecf a3=1 items=0 ppid=2458 pid=2465 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=1 comm="xauth" exe="/usr/bin/xauth" subj=unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-35.fc12,catchall,xauth,xauth_t,admin_home_t,file,unlink
audit2allow suggests:

#============= xauth_t ==============
allow xauth_t admin_home_t:file unlink;
Comment 1 Michal Hlavinka 2009-10-29 04:36:37 EDT
I'm getting this together with preventing: getattr, read, write

Usualy I get this after doing 'su -' in Konsole.
Comment 2 Daniel Walsh 2009-10-29 08:42:55 EDT
Tomas, I think this is related to to the patch I sent you.  Maybe it is only happening in kde environments.
Comment 3 Tomas Mraz 2009-10-29 09:20:52 EDT

*** This bug has been marked as a duplicate of bug 531530 ***
Comment 4 Brian McFadden 2009-10-30 01:21:22 EDT
I get this and several other errors when I use 'su -' in GNOME's Terminal as well.

Note You need to log in before you can comment on or make changes to this bug.