This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 5317 - dhcp client quits too soon during install
dhcp client quits too soon during install
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-22 19:34 EDT by kjw
Modified: 2015-01-07 18:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 08:35:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description kjw 1999-09-22 19:34:47 EDT
using both the rh6.0 and rh6.0-updates net install diskette,
when I try and select DHCP to configure my ip address, I
always get an error back of "no dhcp address required" when
I try and do an install at work.  at home, it works
just fine.

The difference between the two locations is that at home,
the dhcp server responds immediately, whereas at work,
it takes 2-3 seconds to respond, since the dhcp server
is off in another building with dhcp_relay servers in
the middle.

Since the error "No DHCP reply received" comes back in a
FRACTION of a second, my suspicion is that it waits for
too short of a time.

sniffing the network, I do indeed see two bootp packets
go out, and several seconds two more come back, but well
after the "No DHCP reply received" error.

Please make the delay longer??

Here's my sniff log:
0066:   len  622   time 16:32:05.266205
    ether:  src 0:20:af:93:ba:76/3COM     dst
ff:ff:ff:ff:ff:ff
    ip:     src 0.0.0.0                   dst
255.255.255.255
    udp:    sport 68 (bootpc)             dport 67
(bootp)
    bootp:  op REQUEST          xid 0x4aadb9a4
            ciaddr 0.0.0.0                yiaddr
0.0.0.0
            siaddr 0.0.0.0                giaddr
0.0.0.0
            chaddr 0:20:af:93:ba:76

sname

file
            magic 16694854

0067:   len  622   time 16:32:05.267019
    ether:  src 0:20:af:93:ba:76/3COM     dst
ff:ff:ff:ff:ff:ff
    ip:     src 0.0.0.0                   dst
255.255.255.255
    udp:    sport 68 (bootpc)             dport 67
(bootp)
    bootp:  op REQUEST          xid 0x4aadb9a4
            ciaddr 0.0.0.0                yiaddr
0.0.0.0
            siaddr 0.0.0.0                giaddr
0.0.0.0
            chaddr 0:20:af:93:ba:76

sname

file
            magic 16694854

0026:   len  594   time 16:32:11.565100
    ether:  src 0:e0:b0:8a:b6:a8          dst
0:20:af:93:ba:76/3COM
    ip:     src 192.132.200.11            dst
dhcp-b43-51-223.engr.sgi.
    udp:    sport 67 (bootp)              dport 68
(bootpc)
    bootp:  op REPLY            xid 0x4aadb9a4
            ciaddr 0.0.0.0                yiaddr
dhcp-b43-51-223.engr
            siaddr 0.0.0.0                giaddr
b43-11-cisco5-51.eng
            chaddr 0:20:af:93:ba:76
            sname
frick

file
            magic 16694854
Comment 1 Jay Turner 2000-02-08 08:35:59 EST
Did you have the same problem with the 6.1 release?  Please reopen this bug if
you are still having problems.
Comment 2 kjw 2000-02-08 14:34:59 EST
this bug seems to have gone away with rh6.1.

Note You need to log in before you can comment on or make changes to this bug.