Bug 53170 - gnorpm no longer starts after upgrade from default RPM 3.0.4 to rpm 4.0.2
gnorpm no longer starts after upgrade from default RPM 3.0.4 to rpm 4.0.2
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Mason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-04 16:32 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 06:18:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-04 16:32:00 EDT
gnorpm no longer starts after upgrade from default RPM 3.0.4 to rpm 4.0.2

How Reproducible: 100% - gnorpm simply wont start EVER after upgrading
as perinstructions to rpm 4.0.2


Steps to Reproduce:
1. upgrade rpm 3.0.4 to 4.0.2
2. startx
3. start gnorpm

Actual Results:  nothing happens except error message on ctrl+alt+F1 page:
gnorpm-auth: error in loading shared libraries: 
/usr/lib/librpm.so.0 undefined symbol: ufdio

Expected Results: gnorpm runs ok like it did with rpm 3.0.4


Additional Information:
	I have upgraded RPM from zoots standard rpm-3.0.4-0.48.i386.rpm
to a zoot upgrade version rpm-4.0.2-6x.i386.rpm
and it works fine.

The trouble is that gnorpm (gnome-rpm manager) no longer works.
When I start it there is disk activity then NOTHING!

Unfortunately I cant restore the old rpm because redhat instructions say
the new one irrevesibly upgrades the Packages file
in /var/lib/rpm. (i have not tried it though
because of this warning

I tried a newer gnorpm-0.9-27.i386.rpm (instead of the
original gnorpm-0.9-15.i386.rpm

---

I only wanted to install cervisia (a GUI for CVS).
This demanded to be handled by an rpm major version > 3.
Now I have a working rpm4 but no cervisia AND no WORKING gnorpm.

gnorpm reports this error which one can on logout from X:-

gnorpm-auth: error in loading shared libraries: 
/usr/lib/librpm.so.0 undefined symbol: ufdio

When I run the original gnorpm and look at the 
error log by doing CTRL+ALT+F1 

Can anyone say what I need to get gnorpm
going again short of a custom reinstall !!


Bob
r@seabrooks.supanet.com
bob.seabrook@dtrack.com

---
Comment 1 Mike A. Harris 2001-10-23 06:18:40 EDT
The current version for RHL 6.2 is: gnorpm-0.95.1-6.6x.src.rpm

Please upgrade to this version, and if the problem does not go
away, reopen the bug report.  It should work.

Note You need to log in before you can comment on or make changes to this bug.