Bug 53173 - up2date does not work behind authentication proxy
up2date does not work behind authentication proxy
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-04 17:02 EDT by Gil Chilton
Modified: 2015-01-07 18:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 17:56:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gil Chilton 2001-09-04 17:02:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I get the following information whenever I attempt to list or update
using up2date:

[root@localhost rhn]# up2date -l 
 
For this beta release of Red Hat Linux, the up2date program has been
configured to point to a different Red Hat Network server.  This server
(beta.rhns.redhat.com) can be used to obtain updated packages for the
duration of this Red Hat Linux beta test ONLY.  After the beta test has 
been
completed, this Red Hat Network server will no longer be available for use.
 
 
Retrieving list of all available packages...
There was a fatal error communicating with the server.  The message was:
unable to set up CONNECTION tunnel

I have the latest updates from jturner's web site and am fairly confident 
that up2date is configured correctly.  rhn_register works correctly.  
up2date CAN determine that the machine is not entitled to do updates but 
cannot get the updates.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure and run rhn_register
2. Configure and run up2date with -l or -u options
3.
	

Actual Results: No updates but can detect that entitlement is setup or not.

Expected Results:  up2date should list or update components

Additional info:
Comment 1 David Crim 2001-09-05 17:56:26 EDT
I am also having problems from behind an authenticating firewall. The first
Roswell release didn't want to let me configure a proxy. Now, with the second
Roswell installed, I was able to set up the proxy and register, but I get an 
error when running up2date -l --nox. The last couple of lines are:

Retrieving list of all available packages...
There was a fatal error communicating with the server.  The message was:
host not found
Comment 2 Jay Turner 2001-09-06 06:58:04 EDT
These are both known, but separate, bugs.  There are new packages at
http://people.redhat.com/jturner/software.html . . . just grab the 
up2date[-gnome]-2.6.4-7.x.1 packages and see if those work out for you.
Comment 3 David Crim 2001-09-07 12:01:15 EDT
I got the packages from your directory, but they require rpm >= 4.0.3-1 and
rpm-python >= 4.0.3-1. Since the latest rpm version on the BNL mirror of Rawhide 
is 4.0.3-0.96, where can I get this version of rpm? I can't use up2date, since it
doesn't work for me yet.
Comment 4 David Crim 2001-09-07 12:06:06 EDT
Never mind the previous message. I forced the install with the --nodeps option
after resolving all dependencies except the rpm and rpm-python versions. 
Up2date -l --nox seems to be working now. 

Thanks!

Note You need to log in before you can comment on or make changes to this bug.