Bug 531874 - SELinux has prevented vbetool from performing unsafe memory operation
SELinux has prevented vbetool from performing unsafe memory operation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: vbetool (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-29 13:37 EDT by Jóhann B. Guðmundsson
Modified: 2013-01-10 03:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-30 10:27:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The report (2.61 KB, text/plain)
2009-10-29 13:37 EDT, Jóhann B. Guðmundsson
no flags Details
Screenshot showing the load on vbetool (1.76 MB, image/png)
2009-10-30 05:31 EDT, Jóhann B. Guðmundsson
no flags Details
gdb of vbetool (11.62 KB, text/plain)
2009-10-30 05:58 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2009-10-29 13:37:55 EDT
Created attachment 366669 [details]
The report 

Description of problem:

See attache file for details. 

Note I was not offered to report this through SELinux Gui however I was offered to turn off memory protection.

I left the laptop suspended ( closed the lid ) overnight and I think this is the cause for the gui not return after staying suspended for so long ( all I got was a black screen with the mouse pointer keyboard was responding and switching to tty2 work fine and switching back to tty1 ( desktop ) still gave me black screen with only the mouse pointer visible.. then again this all might be a xorg-x11-drv-ati issue note this only seems to happen when the laptop has been suspended for a long period of time.. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2009-10-29 14:18:49 EDT
There is an effort to remove the need for mmap_zero from vbetool.  For now set the boolean and see if suspend/resume works correctly.
Comment 2 Jóhann B. Guðmundsson 2009-10-30 05:30:27 EDT
Uhum it did return after a while with vbetool hogging the cpu. 

It's been running like that for quite a while now which makes one wonder if vbetool is looping..
Comment 3 Jóhann B. Guðmundsson 2009-10-30 05:31:33 EDT
Created attachment 366774 [details]
Screenshot showing the load on vbetool
Comment 4 Jóhann B. Guðmundsson 2009-10-30 05:58:39 EDT
Created attachment 366776 [details]
gdb of vbetool
Comment 5 Jóhann B. Guðmundsson 2009-10-30 10:18:48 EDT
Note GPU ATI M22 Mobility Radeon X300 and this with "nomodeset" redoing the test with KMS ON...
Comment 6 Matthew Garrett 2009-10-30 10:27:24 EDT
The supported suspend/resume configuration for intel, nvidia and radeon is with KMS enabled, at which point vbetool won't be run.

Note You need to log in before you can comment on or make changes to this bug.