Bug 53189 - Voodoo 4500 PCI - hard crash with 3D apps
Summary: Voodoo 4500 PCI - hard crash with 3D apps
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-04 23:20 UTC by Alan Cox
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-15 01:54:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace (24.10 KB, text/plain)
2001-09-05 17:37 UTC, Alan Cox
no flags Details

Description Alan Cox 2001-09-04 23:20:55 UTC
Click on Chromium and the X server hangs (except the mouse pointer). The
rest of the box seems ok. 

As I understand it the PCI Voodoo cards aren't supported for DRI currently
(which is a seperate issue). The machine does have AGP but the AGP is not
being used.

I assume we/XFree86 is accidentally enabling DRI facilities for the PCI
voodoo 4500 as well as the AGP one ?

Comment 1 Bill Nottingham 2001-09-05 02:10:50 UTC
Does it have a *supported* AGP bridge?

It used to try this for PCI r128 as well (before pcigart) with interesting results.

Comment 2 Mike A. Harris 2001-09-05 02:21:31 UTC
All 3dfx hardware IIRC is PCI, even the AGP stuff is just PCI card
in an AGP slot.  I'm using an AGP Voodoo3, and it does not use agpgart
at all.  DRI works fine.  I believe all Voodoo3+ cards, and the Banshee
are all supported.

Most likely, what the problem is, is the glide lib is not properly
symlinked.  I added code to our xinitrc package to run glidelink, however
neglected to add it to startx as well.  I'll add it to startx now.
For the time being, just run glidelink once, and all should be well. This
problem normally wouldn't occur on a fresh install, or upgrade, however
if a Voodoo 4/5 is swapped into a system that wasn't there when the
system was installed, the glide3 lib being pointed to will be the one
for the Voodoo3.  This problem sucks, and the hacks we've put in place
one after the other should be nearing perfection soon.  ;o)  Fortunately,
I hounded upstream about this, and XFree86 4.2.0 should solve it, by having
Mesa directly dlopen() the proper glide3 library at runtime alleviating the
need for glidelink entirely.  It also has the bonus of allowing multiple
3dfx cards to work in multihead configurations where each differs, ie
a V3 and V5 simultaneously.

Please update this to let me know if doing the glidelink mamba fixes the
3D problem.

/me gots to get some V4/5 test hardware...



Comment 3 Alan Cox 2001-09-05 17:01:24 UTC
I will try that and see. The original install was i815 video (which kept hanging
in Roswell2) so it may be relevant. X is running under gdm


Comment 4 Alan Cox 2001-09-05 17:36:49 UTC
Ok glidelink changes the behaviour. Its now merely broken 8)

[root@oggit root]# gears
gd error (glide): gd error (glide): grSstSelect:  non-existent SSTgd error
(glide): grSstSelect:  non-existent SSTSegmentation fault



Comment 5 Alan Cox 2001-09-05 17:37:24 UTC
Created attachment 30955 [details]
strace

Comment 6 Alan Cox 2001-09-15 01:54:38 UTC
Glidelink was the base problem, now it merely doesnt do 3d right and crashes
the machine at rgular intervals

Closing this as the others are down as bugs seperately. XFree 4.1 seems to be
seriously broken. I can't find anything stable that isnt unaccelerated


Comment 7 Mike A. Harris 2001-10-15 09:27:45 UTC
Closing, as you mentioned the bugs are in other reports...  it didn't get
closed somehow...


Note You need to log in before you can comment on or make changes to this bug.