Bug 531974 - Traceback when used with current mercurial in EL-5
Summary: Traceback when used with current mercurial in EL-5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: trac-mercurial-plugin
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-30 03:02 UTC by Toshio Ernie Kuratomi
Modified: 2013-01-10 05:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-28 23:29:30 UTC
Type: ---


Attachments (Terms of Use)

Description Toshio Ernie Kuratomi 2009-10-30 03:02:48 UTC
Description of problem:
Plugin gives traceback with current mercurial in EL-5.

Version-Release number of selected component (if applicable):
mercurial-1.3.1-3.el5
trac-0.10.5-2.el5
trac-mercurial-plugin-0.10.0.3-1.20080318svn8179.el5

How reproducible:
Everytime

Steps to Reproduce:
1. yum update to current version of trac, trac-mercurial-plugin, and mercurial
2.
3.
  
Actual results:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 191, in dispatch
    chosen_handler = self._pre_process_request(req, chosen_handler)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 263, in _pre_process_request
    chosen_handler = f.pre_process_request(req, chosen_handler)
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/api.py", line 73, in pre_process_request
    self.get_repository(req.authname).sync()
  File "/usr/lib/python2.4/site-packages/trac/versioncontrol/api.py", line 104, in get_repository
    repos = self._connector.get_repository(rtype, rdir, authname)
  File "/usr/lib/python2.4/site-packages/tracvc/hg/backend.py", line 99, in get_repository
    return MercurialRepository(dir, self.log, options)
  File "/usr/lib/python2.4/site-packages/tracvc/hg/backend.py", line 165, in __init__
    self.repo = hg.repository(ui=self.ui, path=path)
  File "/usr/lib/python2.4/site-packages/mercurial/hg.py", line 63, in repository
    repo = _lookup(path).instance(ui, path, create)
  File "/usr/lib/python2.4/site-packages/mercurial/localrepo.py", line 2188, in instance
    return localrepository(ui, util.drop_scheme('file', path), create)
  File "/usr/lib/python2.4/site-packages/mercurial/localrepo.py", line 32, in __init__
    self.ui = baseui.copy()
  File "/usr/lib/python2.4/site-packages/mercurial/ui.py", line 39, in copy
    return self.__class__(self)
TypeError: __init__() takes exactly 1 argument (2 given)


Expected results:
Project home page

Additional info:

I've updated this in the EL-5 EPEL build with a new upstream snapshot.  No traceback.  I don't know if this affects any Fedora release or EL-4 so I'm opening this bug.  If they're not affected, feel free to close it.  If it does, the EL-5 branch has the updated spec and tarball.

Comment 1 Fedora Update System 2009-10-30 03:03:41 UTC
trac-mercurial-plugin-0.10.0.3-2.20091029svn8367.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/trac-mercurial-plugin-0.10.0.3-2.20091029svn8367.el5

Comment 2 Fedora Update System 2009-12-01 18:24:20 UTC
trac-mercurial-plugin-0.10.0.3-2.20091029svn8367.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 3 Jesse Keating 2010-05-28 23:29:30 UTC
Closing due to lack of feedback, a few newer builds have been done.


Note You need to log in before you can comment on or make changes to this bug.