Bug 53207 - System hangs on boot when SCSI partition table corrupt
System hangs on boot when SCSI partition table corrupt
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-04 23:11 EDT by csieh
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 06:46:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fdisk and strace output (3.83 KB, text/plain)
2001-09-04 23:12 EDT, csieh
no flags Details

  None (edit)
Description csieh 2001-09-04 23:11:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
After formatting a removeable SCSI disk in Windows '98, Linux would not
boot off of the IDE root partition. Traced problem to fsck hanging due to
bad partition table. See attachment.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fdisk SCSI disk in Linux, assign type 83
2.boot in Windows '98 and format drive 
3.attempt to re-boot Linux
	

Actual Results:  Linux boot hangs after displaying "Checking root filesystem"

Expected Results:  Boot should have checked root partition (/dev/hda2) and
continued.

Additional info:

See attachment for fdisk and strace output.
Workaround is boot in rescue mode and re-partition the disk. (Or remove the
removeable media)
Comment 1 csieh 2001-09-04 23:12:58 EDT
Created attachment 30907 [details]
fdisk and strace output
Comment 2 Florian La Roche 2003-08-12 06:46:40 EDT
This is a config/setup problem to use one geometry setting across several OS
versions installed.

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.