Bug 532088 - Anaconda crashes during live-CD installation when language is set to Norwegian
Anaconda crashes during live-CD installation when language is set to Norwegian
Status: CLOSED DUPLICATE of bug 528317
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-10-30 11:18 EDT by Tore Anderson
Modified: 2009-11-02 09:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-11-02 09:20:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
abrt crash report (1.39 MB, image/png)
2009-10-31 06:16 EDT, Tore Anderson
no flags Details
Sorry, wrong screenshot - this is the right one (108.99 KB, image/png)
2009-10-31 06:17 EDT, Tore Anderson
no flags Details

  None (edit)
Description Tore Anderson 2009-10-30 11:18:59 EDT
Description of problem:

If I boot the Live-CD, selecting Norwegian as the language (and as the keymap) at the GDM login, the Live-CD installer doesn't start.  Instead a popup is shown, telling me that anaconda crashed.  Inspecting this error shows a backtrace that seems to have something to do about finding a default language or something like that.

Interestingly, if I log out, and select «Norsk bokmål» as the language instead (which means «Norwegian bokmål») it works well, and is translated.  Also there's a third option («Norsk nynorsk»).  Nynorsk and Bokmål are the only two official variants of the Norwegian language, so why the live-CD gives me three options rather weird, in my opinion.

Another thing I found odd is that even though I selected the Norwegian keymap during login, when I started the HD installer, US layout was pre-selected.

Version-Release number of selected component (if applicable):

F12 Beta

How reproducible:


Steps to Reproduce:
1. Boot from the Live-CD
2. Select «Norwegian» as the language (literally «Norwegian», not «Norsk bokmål» or «Norsk nynorsk»)
3. Attempt to start the installer
Actual results:

No installer shows up, instead a crash is detected.

Expected results:

I'm able to install normally, just like I am when selecting «Norsk bokmål».

Additional info:
Comment 1 Chris Lumens 2009-10-30 11:29:05 EDT
Please attach the complete traceback to this bug report so we can see what the problem is.
Comment 2 Tore Anderson 2009-10-31 06:14:20 EDT
The automatic reporting tool didn't work, just complained about some missing logger plugin or something like that.  So I'll just attach it as a screenshot instead in a sec.

The missing parts of the report which you won't see because the screen isn't large enough, says:

release Fedora release 11.92 (Rawhide)
uuid 4ad78261

One thing I noticed is that it talks about the "no_NO" locale, which has been deprecated for quite some time - it's replaced by nb_NO and nn_NO (Norwegian bokmål and nynorsk).  So I think what might be happening is that the live-CD login screen sets the language to the deprecated locale, which Anaconda doesn't support, and crashes.

Comment 3 Tore Anderson 2009-10-31 06:16:18 EDT
Created attachment 366908 [details]
abrt crash report
Comment 4 Tore Anderson 2009-10-31 06:17:36 EDT
Created attachment 366909 [details]
Sorry, wrong screenshot - this is the right one
Comment 5 Chris Lumens 2009-11-02 09:20:20 EST

*** This bug has been marked as a duplicate of bug 528317 ***

Note You need to log in before you can comment on or make changes to this bug.