Bug 53218 - Installer removes cups in /etc/init.d and installs LPRng
Installer removes cups in /etc/init.d and installs LPRng
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: distribution (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 01:58 EDT by Joachim Backes
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 09:12:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2001-09-05 01:58:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9 i686)

Description of problem:
I have a RH 7.1 system without LPRng, but with CUPS installed. Now, after
an UPDATE installation of ROSWELL, LPRng is installed, and the cups entry
in /etc/init.d is removed. Bad!

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install RH 7.1
2. Remove LPRng and install CUPS

3. Make an update to roswell
	

Actual Results:  cups no more running, but LPRng

Expected Results:  no LPRng installed (because previously not installed)

Additional info:

--
Comment 1 Michael Fulbright 2001-09-05 11:57:04 EDT
Matt, Crutcher - does the LPRng package Obsolete cups?
Comment 2 Michael Fulbright 2001-09-05 14:42:05 EDT
Was the cups entry in /etc/rc.d/init.d called 'lpd'?

Was cups installed via an RPM?
Comment 3 Joachim Backes 2001-09-06 00:40:50 EDT
Cups had been installed as rpm (cups-1.1.10-0), and the service name in
/etc/init.d was "cups", and not lpd.
Comment 4 Matt Wilson 2001-09-06 08:22:42 EDT
There is no package that obsoletes CUPS:

[msw@localhost msw]$ rpm -qa --dbpath /usr/lib/rpmdb/i386-redhat-linux/redhat/
--qf "[%{NAME} %{OBSOLETENAME}\n]" | grep -i cups
[msw@localhost msw]$ 

The upgrade process never explicitly removes packages.  This has to be a
packaging problem.
Comment 5 Tim Powers 2001-09-06 09:12:02 EDT
Where did you get the cups package from? We have never shipped cups-1.1.10 packages.
Comment 6 Tim Powers 2001-09-06 09:31:24 EDT
Does your cups package have something in the specfile like "Provides: lpr"?

If that's the case, then what is happening is LPRng is also providing lpr, so
whn you do an upgrade the virtual provides of "lpr" is seen by RPM an cups is
upgraded ti LPRng since they both provide "lpr".

This is expected behaviour.

Tim
Comment 7 Joachim Backes 2001-09-06 09:52:25 EDT
I installed the cups-1.1.10-0 rpm from www.cups.org.

rpm -qi --provides cups:

Name        : cups                         Relocations: (not relocateable)
Version     : 1.1.10                            Vendor: Easy Software Products
Release     : 0                             Build Date: Wed Aug 15 21:50:28 2001
Install date: Tue Sep  4 12:09:31 2001      Build Host: poppa.easysw.com
Group       : Applications                  Source RPM: cups-1.1.10-0.src.rpm
Size        : 9707129                          License: 1993-2001 by Easy
Software Products, All Rights Reserved.
Packager    : mike@poppa
Summary     : Common UNIX Printing System
Description :

cups  
cupsys  
cups-devel  
cupsys-devel  
cups-pstoraster  
libcups1  
libcups.so.2  
libcupsimage.so.2  
cups = 1.1.10-0


Comment 8 Tim Powers 2001-09-06 10:10:17 EDT
So cups is still installed along side LPRng? Can you send the output of "rpm -ql
cups" please?  

Tim
Comment 9 Crutcher Dunnavant 2001-09-06 10:34:50 EDT
please attach the cups rpm to this bug.
Comment 10 Tim Powers 2001-09-06 11:07:56 EDT
FWIW, that (cups) is a package we didn't ship, and have not tested WRT
upgrading. We can't gaurantee that it will work at all. It is simular to the
Ximian packages for GNOME. While you can install them, we can't support them if
you have problems.

Tim

Note You need to log in before you can comment on or make changes to this bug.