This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 532201 - KMS:RV770LE:HD4830 Suspending fails on Fedora 13
KMS:RV770LE:HD4830 Suspending fails on Fedora 13
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Jerome Glisse
Fedora Extras Quality Assurance
card_R700/M
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-31 08:33 EDT by Jouni Mäenpää
Modified: 2011-06-27 10:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-27 10:29:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output (38.38 KB, text/plain)
2009-10-31 08:33 EDT, Jouni Mäenpää
no flags Details
xorg log (81.74 KB, text/plain)
2009-10-31 08:34 EDT, Jouni Mäenpää
no flags Details
KMS dmesg (38.77 KB, text/plain)
2009-11-06 12:03 EST, Jouni Mäenpää
no flags Details
KMS xorg.log (48.77 KB, text/plain)
2009-11-06 12:04 EST, Jouni Mäenpää
no flags Details
pm-suspend.log (4.38 KB, text/plain)
2009-11-06 12:18 EST, Jouni Mäenpää
no flags Details
/var/log/messages (159.37 KB, text/plain)
2010-05-27 08:13 EDT, Jouni Mäenpää
no flags Details

  None (edit)
Description Jouni Mäenpää 2009-10-31 08:33:36 EDT
Created attachment 366921 [details]
dmesg output

Description of problem:
Suspending has never worked on my desktop with this card. Tried atleast with F11 & F12 beta. Disabling KMS with nomodeset doesn't help. With KMS I only get hang / blank screen / fans still on, without KMS suspending hangs outputting something like: use no_console_suspend to debug.

Version-Release number of selected component (if applicable):
Atleast F11 & F12 beta

How reproducible:
ALWAYS

Steps to Reproduce:
1. Boot
2. Menu -> Shutdown -> Suspend
3. Hang
  
Actual results:
Hang, restart needed.

Expected results:
Suspend.

Additional info:
Comment 1 Jouni Mäenpää 2009-10-31 08:34:57 EDT
Created attachment 366922 [details]
xorg log
Comment 2 Jouni Mäenpää 2009-10-31 09:15:28 EDT
Components currently in use:
xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73
xorg-x11-server-Xorg-1.7.0-1
kernel-2.6.31.5-96
Comment 3 Matěj Cepl 2009-11-05 12:20:04 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages (at least F12Beta, but even better if the very latest versions).

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 4 Jouni Mäenpää 2009-11-05 19:01:16 EST
Just updated to the latest set of packages. Suspending still doesn't work.
Comment 5 Jerome Glisse 2009-11-06 10:08:03 EST
Jouni please give use package version of:
xorg-x11-server-Xorg
xorg-x11-drv-ati
kernel

That you last tried.
Comment 6 Jerome Glisse 2009-11-06 10:09:27 EST
Please also attach dmesg + xorg log with KMS enabled. Priority for us is KMS.
Comment 7 Jouni Mäenpää 2009-11-06 12:03:46 EST
Created attachment 367846 [details]
KMS dmesg
Comment 8 Jouni Mäenpää 2009-11-06 12:04:47 EST
Created attachment 367848 [details]
KMS xorg.log
Comment 9 Jouni Mäenpää 2009-11-06 12:18:03 EST
Created attachment 367850 [details]
pm-suspend.log
Comment 10 Jouni Mäenpää 2009-11-06 12:21:28 EST
Doesn't work:

xorg-x11-server-Xorg-1.7.1-6.fc12.x86_64
kernel-2.6.31.5-117.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.x86_64
Comment 11 Jerome Glisse 2009-11-10 15:04:53 EST
I wonder if pm-utils is doing something bad. Please boot with kms on and in level 3 (add 3 to kernel boot command line). Then to suspend as root do :
echo -n mem > /sys/power/state

Then report what is the result. Does the computer suspend (all fan stop) ? If so is it resume which doesn't work (when you press button fan starts but you never get the screen back or are not able to log in through ssh) ?
Comment 12 Jouni Mäenpää 2009-11-10 17:07:00 EST
Same result as before. Monitor doesn't go off, blank screen. Fans on.

Tested also with the latest -127 kernel.
Comment 13 Jouni Mäenpää 2009-11-10 17:12:05 EST
With "monitor doesn't go off" I mean some signal is still sent to the monitor as in a successful situation the monitor should display something like: check signal cable...
Comment 14 Bug Zapper 2009-11-16 09:45:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Jouni Mäenpää 2010-01-14 18:03:45 EST
Still no luck with the latest packages:

kernel-2.6.32.3-10.fc12.x86_64 or
kernel-2.6.31.9-174.fc12.x86_64

xorg-x11-drv-ati-6.13.0-0.20.20091221git4b05c47ac.fc12.x86_64
xorg-x11-server-Xorg-1.7.4-1.fc12.x86_64
Comment 16 Mike Hanafey 2010-03-08 09:58:27 EST
I have the same failure to suspend issue with a new F12 installation (installed from LiveCD i686, fully updated) - the screen backlight goes off, the keyboard is dead, but the fan and disk continue to spin. The rest of the hardware is a stock Dell Optiplex 755.

The big difference is my graphics is Nvidia NVS 295. The identical hardware was previously controlled by F10 with no suspend / resume issues. Interestingly, before going to F12 I tried F11 (again fully udated) and this time there was a problem resuming from what seemed to be a successful suspend. In the F11 case upon a hard restart after this failure there was a prompt to send a kernel failure report to kerneloops.org.
Comment 17 Jouni Mäenpää 2010-05-26 15:25:23 EDT
Just installed fresh Fedora 13 on the same hardware (+ SSD / partition). Still no luck with suspending, same symptoms as before.
Comment 18 Jerome Glisse 2010-05-27 04:07:36 EDT
Please boot f13 with following option:
no_console_suspend 3 drm.debug=15

Log in as root and do:
echo -n mem > /sys/power/state

You should see message on screen, if you can resume (i guess you can't) then resume and attach full /var/log/messages if you can resume please take a picture of the screen. Also attach full /var/log/messages before suspending.
Comment 19 Jouni Mäenpää 2010-05-27 08:13:26 EDT
Created attachment 417214 [details]
/var/log/messages

The attached file shows logged messages in /var/log/messages when booting the system with the following extra kernel parameters.

no_console_suspend 3 drm.debug=15

Tried to suspend as root with: echo -n mem > /sys/power/state

--> Blank screen (backlight on) with prompth (_) at the top left corner --> Lock --> Reset button
Comment 20 Jouni Mäenpää 2010-09-01 08:21:09 EDT
Tested with:
kernel-2.6.34.6-47.fc13.x86_64
xorg-x11-drv-ati-6.13.0-1.fc13.x86_64

=> Suspend doesn't work. If I remember correctly, before I just got blank screen, but now the monitor says no signal. Fans still stay on and the system freezes.
Comment 21 Jouni Mäenpää 2010-09-01 12:47:13 EDT
The following kernels from Koji tested not to work:

kernel-2.6.35.4-14.fc14.x86_64   => BLANK SCREEN
kernel-2.6.36-0.12.rc3.git0.fc15.x86_64  => NO SIGNAL

The motherboard of the setup has an Nvidia nforce4 SLI chipset. Are there any known issues with Nvidia chipsets during suspend/resume.
Comment 22 Benjamin Bellec 2011-02-24 15:17:12 EST
I update this issue with the Fedora 15 Radeon Test day (gfx_test_week_20110221_x86-64.iso).

So, when I suspend the computer, it correctly 'shut down' but doesn't resume. My card is an ATI Technologies Inc RV770 [Radeon HD 4850] [1002:9442]

Tell me if you want more information, tests, etc.
Comment 23 Bug Zapper 2011-06-02 13:31:57 EDT
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 24 Bug Zapper 2011-06-27 10:29:26 EDT
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.