Bug 532244 - Duplicate ri manuals for Trollop is installed
Summary: Duplicate ri manuals for Trollop is installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-ditz
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jan Klepek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-31 19:10 UTC by Mamoru TASAKA
Modified: 2009-11-20 23:28 UTC (History)
1 user (show)

Fixed In Version: 0.5-5.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-04 12:12:47 UTC


Attachments (Terms of Use)

Description Mamoru TASAKA 2009-10-31 19:10:04 UTC
Description of problem:
Installing rubygem-ditz also installs rubygem-trollop. After
this, for example (with ruby-ri installed)
$ ri Trollop::Parser#opt
shows:
---------------------------------------------------------
More than one method matched your request. You can refine
your search by asking for information on one of:

     Trollop::Parser#opt, Trollop::Parser#opt
----------------------------------------------------------
i.e. there are two Trollop::Parser#opt ri manuals installed on
     the system, which should be one.

Version-Release number of selected component (if applicable):
rubygem-trollop-1.15-1.fc12.noarch
rubygem-ditz-0.5-4.fc12.noarch

How reproducible:
100%

Steps to Reproduce:
1. yum install ruby-ri rubygem-ditz
2. ri Trollop::Parser#opt
3.
  
Actual results:
see above

Expected results:
$ ri Trollop::Parser#opt should return Trollop::Parser#opt manual.
With only rubygem-trollop installed, this returns:
+++++++++++++++++++++++++++++++++++++++++++++++
---------------------------------------------------- Trollop::Parser#opt
     opt(name, desc="", opts={})
------------------------------------------------------------------------
     Define an option. +name+ is the option name, a unique identifier
     for the option that you will use internally, which should be a
     symbol or a string. +desc+ is a string description which will be
     displayed in help messages.
......
......
+++++++++++++++++++++++++++++++++++++++++++++++

Additional info:
This is because rubygem-ditz-0.5-4.fc12.noarch rpm also installs
ri manuals for Trollop (under
/usr/lib/ruby/gems/1.8/doc/ditz-0.5/ri/Trollop ).
I should have noticed this issue on the review...

Note that until recently ri command was completely broken for ri manuals
installed via gem (see bug 528787). Fixed ruby-ri is available on
the newest F-12 rawhide / F11-updates-testing.

Comment 1 Jan Klepek 2009-11-01 18:17:10 UTC
fixed

Comment 2 Fedora Update System 2009-11-01 19:12:42 UTC
rubygem-ditz-0.5-5.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/rubygem-ditz-0.5-5.el5

Comment 3 Fedora Update System 2009-11-01 19:12:46 UTC
rubygem-ditz-0.5-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rubygem-ditz-0.5-5.fc11

Comment 4 Fedora Update System 2009-11-01 19:12:51 UTC
rubygem-ditz-0.5-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rubygem-ditz-0.5-5.fc10

Comment 5 Fedora Update System 2009-11-03 01:57:34 UTC
rubygem-ditz-0.5-5.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rubygem-ditz'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0776

Comment 6 Fedora Update System 2009-11-04 12:12:42 UTC
rubygem-ditz-0.5-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2009-11-04 12:16:57 UTC
rubygem-ditz-0.5-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Mamoru TASAKA 2009-11-05 18:12:05 UTC
I think for F-12 it is better that you ask rel-eng team to get
the fixed rubygem-ditz tagged as f12-final.

Comment 9 Fedora Update System 2009-11-20 23:27:59 UTC
rubygem-ditz-0.5-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.