Bug 53231 - (i810) Screen freezes after leaving a Gnome session
(i810) Screen freezes after leaving a Gnome session
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 05:38 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 04:50:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration file + log file (111.96 KB, text/plain)
2001-10-01 05:46 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-09-05 05:38:02 EDT
Description of Problem:
I sometimes have troubles when leaving a Gnome Session : the screen 
remains black, with no activity on the system. 
Action on CTRL+ALT+SUPPR sometimes works (that is : the system reboots) 
but other times don't work and I then have to turn my computer off. In 
that case, there is of course a risk that fsck fails while rebooting and 
the system may not be usable anymore (which already happened a few times).



Version-Release number of selected component (if applicable):
RedHat 7.0 
PC HP Vectra VL400, Pentium 3 800MHz, 128Mo RAM

How Reproducible:
Not everytime!

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
he problems occurs from time to time on all of the 6 PCs I'm using but 
never happens on another one which is not an HP Vectra.
Could this be a hardware problem? BIOS?
Comment 1 Mike A. Harris 2001-09-23 06:45:00 EDT
This bug was submitted misassigned it appears.

Is this problem still relevant?  If so, can you please attach your
X server log, and config file.

Thanks.
Comment 2 Need Real Name 2001-10-01 05:46:28 EDT
Created attachment 33058 [details]
Configuration file + log file
Comment 3 Need Real Name 2001-10-12 05:36:08 EDT
The problem is still relevant.
How come there is still no response after a so long amount of time? (I've 
submitted logs 11 days ago)

Can the problem be related to an i810 driver problem?
Already found some related problems?
Can XFree86.4.1.0 be a solution?
Comment 4 Mike A. Harris 2001-10-15 05:26:00 EDT
XFree86 4.1.0 might solve it.  I don't have i8xx video hardware to test
with or debug.  It is possible that this is the VT switch hang bug that
is not hardware specific.  A fix for that has just appeared, so I'm
flagging this report for testing once the patch is integrated.
Comment 5 Need Real Name 2001-10-16 12:11:03 EDT
Last News :
I've installed XFree86 v4.1.0 (from xfree86.org) and tried to use it on one of 
my hardware configurations.
I've started my computer on init level 3 and I've tried to use X alone (that 
is : without gdm) : I launch it via an "xinit".

From that point, I never saw a problem when leaving a session but another 
problem sometimes occurs when I start a new session : X acnnot be launched and 
I've got a blank screen. When login from another computer by telnet, the log 
file XFree86.0.log just says "Fatal server error". It doesen't speak of "VT 
switch" anymore but the result is the same : I have to reboot by CTRL+ALT+SUPPR.

Any idea?
Comment 6 Mike A. Harris 2002-06-06 04:08:46 EDT
Does this problem still occur in Red Hat Linux 7.3 with XFree86 4.2.0?
Comment 7 Don Jordan 2002-07-01 18:17:38 EDT
Regarding original issue:
RH 7.3, i386 platform, XFree86 4.2.0

Screen freezes upon logout of X session and will not recover without hard re-
boot.

Comment 8 Don Jordan 2002-07-01 18:21:41 EDT
System:
ARM CL10 (Original Compal ACL10) Laptop P4 1.7GHz, nVidia NV17 32MB DDR 
chipset, using nVidia provided drivers and open GL.
Comment 9 Mike A. Harris 2002-08-08 04:50:30 EDT
Nvidia's proprietary drivers are not provided nor supported by
Red Hat.  Any bugs experienced using Nvidia's proprietary drivers
should be reported directly to Nvidia, as should all technical
support related issues using their drivers.

This bug (the i810 stuff) has been resolved in rawhide XFree86 4.2.0
recently, and is a duplicate of a newer reported bug.

Closing as duplicate.
Comment 10 Mike A. Harris 2002-08-08 04:54:18 EDT
Doh, couldn't mark as duplicate, closing as RAWHIDE instead.
Comment 11 Mark J. Cox (Product Security) 2003-06-25 11:52:39 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2003-066.html

Note You need to log in before you can comment on or make changes to this bug.