Bug 53246 - GUI Installer bombs out after package selection
Summary: GUI Installer bombs out after package selection
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.3
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
Depends On:
TreeView+ depends on / blocked
Reported: 2001-09-05 14:17 UTC by Frank Sweetser
Modified: 2007-04-18 16:36 UTC (History)
0 users

Clone Of:
Last Closed: 2001-10-01 16:05:23 UTC

Attachments (Terms of Use)
Gdk and Gtk error messages (1.28 KB, text/plain)
2001-09-06 15:12 UTC, Frank Sweetser
no flags Details

Description Frank Sweetser 2001-09-05 14:17:03 UTC
Standard install (enter at syslinux prompt), tried both "Custom" and
"Laptop" install.  Everything works fine, until package selection.  After
picking categories, and hitting "Next", the checking dependancies window
pops up for a second or two, then the installer exits abnormally - no

Works fine in text mode installer.

Comment 1 Michael Fulbright 2001-09-05 15:28:06 UTC
How  much RAM do you have?

Could you look on VC3 and VC4 for any error messages?

Comment 2 Frank Sweetser 2001-09-05 16:54:17 UTC
128M memory.  The last line on VC3 is
Swap attempt of 128M to 256M

No errors on VC4.

Comment 3 Michael Fulbright 2001-09-05 18:41:15 UTC
Is this a CDROM or NFS based install?

We've done tons of these cases and haven't seen your problem, so I'm trying to
figure out if there is a hardware issue involved.

What is the hardware?

Comment 4 Frank Sweetser 2001-09-05 18:48:53 UTC
HP Omnibook 6000 CD based install, ATI Rage Mobility Pro 8M video card.  I'll
try reburning the discs tonight to double check the media.

Comment 5 Matt Wilson 2001-09-06 00:52:44 UTC
OK, let us know when you've verified the media.

Comment 6 Frank Sweetser 2001-09-06 15:05:21 UTC
Burned a fresh out-of-the-box CD, reverified md5sum, same results.  Also
attaching string of gdk and gtk error messages (these seem to have been there in
previous installer, attaching in case they're relevant).

Comment 7 Frank Sweetser 2001-09-06 15:12:00 UTC
Created attachment 31095 [details]
Gdk and Gtk error messages

Comment 8 Matt Wilson 2001-09-06 16:19:44 UTC
try using the nofb option at boot.

This is 100% reproducable, correct?

Comment 9 Frank Sweetser 2001-09-06 16:29:41 UTC
Still happens with nofb at boot, and yes, it's 100% reliable.

Comment 10 Michael Fulbright 2001-09-06 16:44:45 UTC
Hmm the gdk/gtk messages are harmless (but noisy).

Did you try ide=nodma when you booted?

Comment 11 Frank Sweetser 2001-09-06 18:35:54 UTC
Booted install with 'linux ide=nodma', same result.

Comment 12 Matt Wilson 2001-09-06 19:36:52 UTC
you're not doing individual package selection, correct?

Comment 13 Frank Sweetser 2001-09-06 20:42:43 UTC
Correct - package group selection only.

Comment 14 Matt Wilson 2001-09-06 20:49:17 UTC
have any of the Fairfax releases installed?

Comment 15 Frank Sweetser 2001-09-06 20:57:19 UTC
Yes - RC1 installed with no problems.

Comment 16 Frank Sweetser 2001-09-11 15:33:01 UTC
Still present in enigma...

Comment 17 Brent Fox 2001-09-13 21:36:17 UTC
Does TUI install work ok?  We haven't seen this behavior in any of our testing.
 Of course, we don't have your exact hardware...

Comment 18 Frank Sweetser 2001-09-14 01:14:31 UTC
Yes, TUI works fine.

Another data point:  exact same problem, equally reproducable, on my desktop at 
home, which has an ATI Rage Pro Turbo AGP 2X video card.

Comment 19 Brent Fox 2001-09-20 18:18:33 UTC
Hmm...contrary to what msf said earlier, I think the problem is related to the
GTK errors somehow.  You should not be seeing those messages, and since the
md5sums check out and TUI works fine, it's not the cdrom's problem.

Have you tried booting with 'linux lowres nofb' and seeing if that makes a

Comment 20 Brent Fox 2001-10-01 16:03:53 UTC
Any more info here?

Comment 21 Frank Sweetser 2001-10-01 16:05:18 UTC
Nope - same results...

Comment 22 Brent Fox 2001-10-02 20:23:35 UTC
I tried Enigma with an ATI Rage Pro Turbo and the install completed
successfully.  I don't know what is causing the problems that you are seeing,
and I am unable to reproduce them.  Resolving as Worksforme.

Note You need to log in before you can comment on or make changes to this bug.