Bug 53253 - nautilus vs. eject creates multiple desktop icons for /mnt/cdrom
Summary: nautilus vs. eject creates multiple desktop icons for /mnt/cdrom
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nautilus   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-05 16:00 UTC by Rob Landry
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 13:42:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Landry 2001-09-05 16:00:15 UTC
Description of Problem:
For each cd inserted a new icon is created without the old on being removed
first.

Version-Release number of selected component (if applicable):
Whatever is in RC2

How Reproducible:
Everytime

Steps to Reproduce:
1.regular install 
2. insert a cd while nautilus is running it will create a desktop icon for it
3. run eject
4. eject will umount and eject the cd leaving the icon
5. insert another cd and you will now have two icons with different lables
6. repeat steps 2-5 to create as many non deletable cd icons with different
labels as you want.

Actual Results:
 see above

Expected Results:
When /mnt/cdrom is unmount by eject nautilus should remove the desktop icon
for that mount and then re-create a new one for the new cd.

Additional Information:
	Machine only has one cdrom drive so two cd icons should never appear

Comment 1 Rob Landry 2001-09-05 19:10:08 UTC
Moved to Beta1 as per instructions on submission page to list Fairfax bugs as
beta1 not RC2.

Comment 2 Owen Taylor 2001-09-06 00:23:23 UTC
The problem here is a race condition that occurs because eject now 
unmounts and ejects the disc if it is unmounted.

The race is if the disc is ejected before nautilus notices that
it is unmounted, then it doesn't know what icon on the desktop
to delete.

I have a tentative patch for this which seems to work and makes
sense to me. I've mailed nautilus-list asking if my assumptions
on how it is supposed to be working are correct or not.


Comment 3 Owen Taylor 2001-09-06 13:42:11 UTC
Fixed in 1.0.4-42.


Note You need to log in before you can comment on or make changes to this bug.