This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 53258 - TUI: traceback when adding a partition to an auto-partitioned map
TUI: traceback when adding a partition to an auto-partitioned map
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 13:19 EDT by Ben Levenson
Modified: 2007-03-26 23:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 14:58:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (20.06 KB, text/plain)
2001-09-05 13:28 EDT, Ben Levenson
no flags Details

  None (edit)
Description Ben Levenson 2001-09-05 13:19:23 EDT
Description of Problem:
The following traceback occurred while adding a partition.
Steps to Reproduce:
1. TUI install
2. Auto-partition + clear all partitions
3. review the partition map and add a partition to available free space
   by hi-lighting it and typing <Enter>
4. specify the size of the partition in MB (not cylinder boundaries)

I received this traceback while trying to create a 6000M partition in
the 6600+ megs available.  This is not an issue w/ GUI installs because
you can't specify the size of the partition when it is created in this
manner.

Version-Release number of selected component (if applicable):
build re0904.0
anaconda-7.1.95-2.i386.rpm

How Reproducible:
100%

Additional Information:
The system has 2 8675M SCSI drives.
Auto-partitioning resulted in the following map:
            start    end    size    type    mount
/dev/sda
     sda1     1       6      47M     ext3    /boot
     sda2     7       260   1992M    swap
Free Space    261     1106  6636M    Free Space

/dev/sdb
     sdb1     1       1106  8675M    ext3     /

Adding the partition works w/out error if I accept the default settings
in the dialog box.  Similar tracebacks occurr if I try to add partitions
as small as 3000M. I was able to add a 2000M partition in this manner.
Seems to be independent of installation type -- verified w/ FTP and NFS
installs.
Comment 1 Ben Levenson 2001-09-05 13:28:14 EDT
Created attachment 30954 [details]
traceback
Comment 2 Michael Fulbright 2001-09-05 14:39:33 EDT
Jeremy?
Comment 3 Jeremy Katz 2001-09-05 15:21:35 EDT
fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.