This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 532618 - Desktop Effects always starts with Wobbly Disabled when having compiz
Desktop Effects always starts with Wobbly Disabled when having compiz
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: desktop-effects (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-02 22:38 EST by Hicham HAOUARI
Modified: 2010-04-13 21:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: desktop-effects-0.8.5-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 21:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
this patch delay the signals connections to after loading and setting up the complete ui (1.59 KB, application/octet-stream)
2009-11-02 22:38 EST, Hicham HAOUARI
no flags Details

  None (edit)
Description Hicham HAOUARI 2009-11-02 22:38:29 EST
Created attachment 367254 [details]
this patch delay the signals connections to after loading and setting up the complete ui

Description of problem:
if u have compiz enabled via desktop-effects, enable wobbly windows, close the dialog, reopen it : wobbly are disabled

Version-Release number of selected component (if applicable):
desktop-effects-0.8.4-2.fc12.i686

How reproducible:
Always

Steps to Reproduce:
1.Open Desktop Effects, check compiz, wobbly, and cube
2.close the dilog
3.reopen it : wobbly is disabled
  
Actual results:
if we have wobbly and cube, opening desktop-effects disables wobbly

Expected results:
if we have wobbly and cube, opening desktop-effects won't disable wobbly

Additional info:
I didn't understand the problem exactly, nevertheless, the attached patch solves it
Comment 1 Owen Taylor 2009-11-03 16:15:51 EST
Looking at it, the problem is that on_option_toggled() handles both the cube and wobbly settings. When we are setting up the widgets, we first change the value of 'cube' and then the value of 'wobbly', so if we set 'cube' to true, then on_option_toggled() will be called before the wobbly toggle button is set, so we'll think the user has disabled wobbly.

Your fix seems like a reasonable approach to fixing the issue. 

(The other approach I could imagine would be to split on_option_toggled() into an on_cube_toggled() and an on_wobbly_toggled(). But your approach is as good.)

Do you think you could redo it as a proper git patch ?

If you aren't familiar with git: use 'git commit' to commit it locally to a checkout of the desktop-effects git repostory. Make sure you've set your name and email as described in, say, http://help.github.com/git-email-settings/. The commit message should consist of a single short line that summarizes what the commit does, a blank line, then a detailed description of what was changed and (more importantly) why. Then format the commit as a patch using 'git format-patch HEAD -1' and attach the resulting file.

Not sure if we'll be able to get this in right now during the beta freeze. Do you happen to know if this was a regression from F11? It's not apparent to me from reading the code - my guess would that probably it did regress but I'm not completely sure of that.
Comment 2 Bug Zapper 2009-11-16 09:57:34 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Owen Taylor 2009-12-29 09:48:20 EST
Do not know why this bug was closed, reopening.
Comment 4 Fedora Update System 2010-04-06 14:47:46 EDT
desktop-effects-0.8.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/desktop-effects-0.8.5-1.fc13
Comment 5 Fedora Update System 2010-04-06 20:01:18 EDT
desktop-effects-0.8.5-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/desktop-effects-0.8.5-1.fc12
Comment 6 Fedora Update System 2010-04-07 16:54:39 EDT
desktop-effects-0.8.5-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update desktop-effects'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/desktop-effects-0.8.5-2.fc13
Comment 7 Fedora Update System 2010-04-08 21:26:11 EDT
desktop-effects-0.8.5-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update desktop-effects'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/desktop-effects-0.8.5-1.fc12
Comment 8 Fedora Update System 2010-04-13 21:32:13 EDT
desktop-effects-0.8.5-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-04-13 21:38:43 EDT
desktop-effects-0.8.5-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.