Bug 53273 - kapm-idled consumes an excessive amount of CPU time
Summary: kapm-idled consumes an excessive amount of CPU time
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-05 22:40 UTC by Landon Curt Noll
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 00:48:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Landon Curt Noll 2001-09-05 22:40:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.2.19-7.0.8 i686)

Description of problem:
The kapm-idled process consumes an excessive amount of CPU time on my
IBM Thinkpad 770Z running RH7.1  Typically it is consuming ~75% of the CPU
leaving only 25% CPU for idle time.

The system is fairly sluggish when this process is consuming CPU time. 
Background
niced processes get almost no CPU time.

Because this is a kernel process, one cannot even kill it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run top on an IBM Thinkpad 770Z
2.
3.
	

Actual Results:  Process 3 is hugging ~75% of the CPU.

Expected Results:  An idle system would have nearly 100% of the CPU
available.

Additional info:

Comment 1 Landon Curt Noll 2001-09-06 00:43:37 UTC
When I re-build the kernel with CONFIG_APM_CPU_IDLE not set, the
kapm-idled no longer became a CPU hog.

Is that a bug or a feature?  If feature, it is certainly a mis-feature on
the IBM Thinkpad 770Z.

Comment 2 Landon Curt Noll 2001-09-06 00:48:42 UTC
Changed the sevarity to Normal since there is a work-a-round to
compile a kernel without CONFIG_APM_CPU_IDLE.

Comment 3 Arjan van de Ven 2001-09-06 08:26:33 UTC
It's a feature. kapm-idled is ALSO the idle task, but the one where your laptop
goes into powersave mode during idle.....
I agree it's a bit confusing to see it show up though.


Note You need to log in before you can comment on or make changes to this bug.