Bug 53279 - NFS broken several different (related?) ways
NFS broken several different (related?) ways
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nfs-server (Show other bugs)
7.1
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 20:20 EDT by John Morris
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-30 17:39:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Morris 2001-09-05 20:20:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
Writable exports which are subsets of larger read-only filesystems don't
work at all, unlike earlier versions.  While trying to develop a workaround
NFS became totally confused, with all nfsd threads on the 7.1 box
repeatedly dying off.  Finally, the server simply refused any attempt by
the 6.2 box to mount anything, even after power cycling both client and
server.  Learned about /var/lib/nfs through the magic of the strings
command.  :)  Had to stop nfs, clean out all references to the affected
client machine from that directory and restart nfs before it could do
anything.  Also seeing random file corruption.  tgz files written to the
nfs server sometimes fail to unpack with crc errors.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create an /etc/exports file as shown below
2. Mount the base share
3. Attempt to find a way to write to the writable subshare.
	

Actual Results:  Read only filesystem

Expected Results:  Writable files

Additional info:

Here is a subset of the /etc/exports file which illustrates the various
failures:

/cdfarm         mjolnir.beau.lib.la.us(rw,no_root_squash)
/cdfarm/images  204.196.62.0/255.255.255.0(rw,no_root_squash)
/cdfarm         204.196.62.0/255.255.255.0(ro)

With these lines, mjolnir can mount with full R/W rights.  When /cdfarm is
mounted on our patron machines they get readonly access.  However when the
server ran the userspace NFSd under RH5.1 /cdfarm/images would be writable.
 Any attempt to recreate this functionality fails.  Mounting /cdfarm/images
seperately on the workstation fails when mounted on top of the read-only
position, fails when mounted on a seperate mountpoint, etc.  Mess with it
enough and it gets really pissed and shoots back. I did get it to mount if
I first umounted /cdfarm from /mnt/server but that was also how I got the
corrupted tarball.  A second attempt and verify pass succeeded.
Comment 1 Rex Dieter 2001-09-06 11:24:54 EDT
From the NFS-HOWTO: http://nfs.sourceforge.net/nfs-howto/server.html
"A few cautions are in order about what cannot (or should not) be exported. 
First, if a directory is exported, its parent and child directories cannot be 
exported if they are in the same filesystem. However, exporting both should 
not be necessary because listing the parent directory in the /etc/exports file 
will cause all underlying directories within that file system to be exported."

In short, I don't believe the the current nfs-utils implementation will allow 
want you are trying to do... even though the old user-space nfs did.


Note You need to log in before you can comment on or make changes to this bug.