Bug 53284 - The kernel fails to revalidate the symlink provided by Amd.
The kernel fails to revalidate the symlink provided by Amd.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: am-utils (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Aaron Brown
None
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-05 20:38 EDT by Shishir Pandya
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 6.0.9-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 04:39:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shishir Pandya 2001-09-05 20:38:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12smp i686)

Description of problem:
The remote filesystem is mounted, then timed-out, and then it is never
auto-mounted again.
The kernel doesn't allow unmounting the direct mountpoint itself, making it
impossible to restart Amd without rebooting.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Mount a remote system(I mount an SGI octane running IRIX6.5) via amd
2.cd to a directory on the amd mounted system and leave it untouched for a
few minutes.
3.do "df" in a separate shell to find
slinux01:/home/pandya:3 >df
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda1              4134900   1843020   2081832  47% /
/dev/sda5              9288792   8678012    138876  99% /u
/dev/sda7              3194048   1318468   1713328  44% /usr/INA
og:/scratch                  0         1         0   0%
/amd/og/root/scratch
og:/scratch2                 0         1         0   0%
/amd/og/root/scratch2
og:/scratch3                 0         1         0   0%
/amd/og/root/scratch3
og:/u/wk                     0         1         0   0% /amd/og/root/u/wk

	

Actual Results:  The amd links hang and report zero size in "df".
The directories which were mounted are now inaccessible.

Only recourse is to reboot the machine.  This often fails because on reboot
it complains that it can not shutdown amd due to live links.

Expected Results:  If I have "cd"'d to a directory via amd, the link should
remain active a s long as I am in that directory.

Additional info:

At the URL
http://www.am-utils.org/patches/
there is a patch for some of the LINUX kernels, but the patch must not have
been aplied to the redhat distributed kernels.

I am submitting this report to make sure that future versions of reshat
distributions include this patch.

Note You need to log in before you can comment on or make changes to this bug.