Bug 532915 - Thunderbird 3.0 Beta 4 applies retention policy to all folders
Thunderbird 3.0 Beta 4 applies retention policy to all folders
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
rawhide
All Linux
high Severity urgent
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
: Reopened
: 528229 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-11-04 05:21 EST by Andreas Thienemann
Modified: 2009-12-05 15:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-13 14:48:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 515316 None None None Never
Mozilla Foundation 527267 None None None Never

  None (edit)
Description Andreas Thienemann 2009-11-04 05:21:19 EST
Description of problem:
The Thunderbird installation on this system is set to use an IMAP server with several folders:

 +-> INBOX
 \+-> Drafts
 \+-> Sent
 \+-> Foo
  \+-> Bar
  \+-> Baz

If one right clicks on Bar and selects Properties in the context menu one can set a retention policy for a folder.

As it is set on a folder basis it is implied that this rule only applies for that one folder.

If one checks the retention policy for every any folder though, one sees that this new policy has been set globally for every single folder, deleting mail one might wanted to keep.


Version-Release number of selected component (if applicable):
thunderbird-3.0-2.8.b4.fc11.x86_64
Comment 1 Matěj Cepl 2009-11-07 18:55:07 EST
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=527267) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 2 Matěj Cepl 2009-11-10 11:08:45 EST
*** Bug 528229 has been marked as a duplicate of this bug. ***
Comment 3 Mike McLean 2009-11-10 12:32:43 EST
The bug can destroy users' data. I'm all for working with upstream, but we need to get the fix into Fedora with all speed.

From the upstream bug, it looks like the issue is resolved. Can someone confirm that we have the fix? If not, can we get a new build?
Comment 4 Andreas Thienemann 2009-11-10 12:42:34 EST
I can confirm that this bug is _NOT_ fixed in fedora.

Reopening.
Comment 5 Gavin Burris 2009-11-11 14:52:55 EST
This bug bit me hard.  I tried to change the retention policy on an IMAP folder for some disposable list mail, and it applied the retention policy to my Archives folders, too.  It deleted all of my archived mail, except the last 2000.  This is a serious problem.  Please push on this.
Comment 6 Matěj Cepl 2009-11-13 14:48:12 EST
(In reply to comment #4)
> I can confirm that this bug is _NOT_ fixed in fedora.
> 
> Reopening.  

No, it hasn't been fixed in bugzilla, read comment 1 once more please. And yes I was bitten by this myself and I lost some important mails because of this.
Comment 7 Mike McLean 2009-11-13 15:47:47 EST
Matej, the upstream bug you referenced in comment 1 is closed as a duplicate of upstream #515316, which is itself in the 'RESOLVED FIXED' state and has an attached patch. From the comments, the fix is checked in and seems to resolve the problem.
https://bugzilla.mozilla.org/show_bug.cgi?id=515316

Given that, it really seems like we ought to pull in the fix. If the fix is inadequate in some way, then we really need to let upstream know.

If there is some other upstream bug or discussion that we are blocking on, then please link.
Comment 9 Hugo van der Kooij 2009-12-05 15:31:33 EST
It seems a fix has been created for almost 2 months now:

David :Bienvenu      2009-10-09 06:39:12 PDT
fix checked in.

It puzzles me why such a significant bug is still left unpatched. I use mainstream Fedora 11 and I have to put up with beta versions on a main distribution.

This is a great advertisement to use anything but Fedora if you will not even try to import upstream patches: https://bug515316.bugzilla.mozilla.org/attachment.cgi?id=405334

Note You need to log in before you can comment on or make changes to this bug.