Bug 532924 - X hangs with kernel-2.6.31.5-115.fc12.x86_64
Summary: X hangs with kernel-2.6.31.5-115.fc12.x86_64
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-04 11:18 UTC by Martin Naď
Modified: 2009-11-22 10:21 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-06 13:28:46 UTC
Type: ---


Attachments (Terms of Use)
kdm log with some backtraces (68.72 KB, text/plain)
2009-11-04 11:18 UTC, Martin Naď
no flags Details
dmesg.old (37.37 KB, text/plain)
2009-11-04 11:19 UTC, Martin Naď
no flags Details
Xorg.0.log.old (30.05 KB, text/plain)
2009-11-04 11:21 UTC, Martin Naď
no flags Details
dmesg on 117 (34.88 KB, text/plain)
2009-11-04 21:02 UTC, Martin Naď
no flags Details
dmesg on 113 (37.14 KB, text/plain)
2009-11-04 21:07 UTC, Martin Naď
no flags Details

Description Martin Naď 2009-11-04 11:18:18 UTC
Created attachment 367442 [details]
kdm log with some backtraces

Description of problem:
X hangs when login to KDE(use autologin) (keyboard not works ,mouse works only
move with cursor)  

Version-Release number of selected component (if applicable):
kernel-2.6.31.5-115.fc12.x86_64
xorg-x11-server-Xorg-1.7.1-1.fc12.x86_64
xorg-x11-drv-nouveau-0.0.15-16.20091030git5587f40.fc12.x86_64

How reproducible:
everytime

Steps to Reproduce:
1.try to start X
  
Actual results:


Expected results:


Additional info:
with kernel-2.6.31.5-112.fc12.x86_64 not hangs

Comment 1 Martin Naď 2009-11-04 11:19:16 UTC
Created attachment 367443 [details]
dmesg.old

Comment 2 Martin Naď 2009-11-04 11:21:23 UTC
Created attachment 367444 [details]
Xorg.0.log.old

Comment 3 Michal Schmidt 2009-11-04 11:24:58 UTC
Ben,

kernel -112 worked, with -115 it hangs, so it's a regression. The changelog shows
these changes by you in -114:

- nouveau: provide info userspace needs to handle low memory situations
- nouveau: fix for rh#532711
- nouveau: add option to provide more debug info for rh#532579
- patch only so large because of included register rename

Comment 4 Michal Schmidt 2009-11-04 11:30:20 UTC
From the kdm.log:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x49e898]
1: /usr/bin/X (mieqEnqueue+0x1f4) [0x49e264]
2: /usr/bin/X (xf86PostMotionEventP+0xce) [0x478f0e]
3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f9c7df27000+0x3f4f) [0x7f9c7df2af4f]
4: /usr/bin/X (0x400000+0x6be17) [0x46be17]
5: /usr/bin/X (0x400000+0x116ad3) [0x516ad3]
6: /lib64/libpthread.so.0 (0x7f9c84c35000+0xf320) [0x7f9c84c44320]
7: /lib64/libc.so.6 (ioctl+0x7) [0x7f9c834c1c07]
8: /usr/lib64/libdrm.so.2 (drmIoctl+0x23) [0x7f9c80f4a203]
9: /usr/lib64/libdrm.so.2 (drmCommandWrite+0x1b) [0x7f9c80f4a48b]
10: /usr/lib64/libdrm_nouveau.so.1 (0x7f9c808ea000+0x2d5d) [0x7f9c808ecd5d]
11: /usr/lib64/libdrm_nouveau.so.1 (nouveau_bo_map_range+0x10b) [0x7f9c808ecf6b]
12: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (0x7f9c80aef000+0xbfb8) [0x7f9c80afafb8]
13: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (0x7f9c80aef000+0xd1a0) [0x7f9c80afc1a0]
14: /usr/lib64/xorg/modules/libexa.so (0x7f9c7f08d000+0x8120) [0x7f9c7f095120]
15: /usr/bin/X (0x400000+0x152bc4) [0x552bc4]
16: /usr/lib64/xorg/modules/libexa.so (exaGetPixmapFirstPixel+0xa9) [0x7f9c7f09c009]
17: /usr/lib64/xorg/modules/libexa.so (0x7f9c7f08d000+0xe285) [0x7f9c7f09b285]
18: /usr/bin/X (0x400000+0xd1c40) [0x4d1c40]
19: /usr/bin/X (0x400000+0xcb7ce) [0x4cb7ce]
20: /usr/bin/X (0x400000+0x2c69c) [0x42c69c]
21: /usr/bin/X (0x400000+0x21cfa) [0x421cfa]
22: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f9c83406b4d]
23: /usr/bin/X (0x400000+0x218a9) [0x4218a9]

Comment 5 Martin Naď 2009-11-04 11:54:15 UTC
with kernel 2.6.31.5-113.fc12.x86_64 not hangs

Comment 6 Ben Skeggs 2009-11-04 13:14:22 UTC
Are you absolutely certain it's the kernel?  I've just looked over the patch again that went into -115, there's nothing I can see that's even remotely relevant.

Comment 7 Martin Naď 2009-11-04 19:24:44 UTC
I tried 2.6.31.5-117.fc12.x86_64 with KMS X hangs without KMS X start normal

Comment 8 Michal Schmidt 2009-11-04 19:54:08 UTC
Martin,
are you 100% sure that when you boot with the -113 kernel (which does not hang), it runs with KMS? Could you provide dmesg from it?

Comment 9 Martin Naď 2009-11-04 21:02:53 UTC
Created attachment 367536 [details]
dmesg on 117

dmesg from 117 without KMS

Comment 10 Martin Naď 2009-11-04 21:07:49 UTC
Created attachment 367538 [details]
dmesg on 113

dmesg from -113 with KMS

Comment 11 Ben Skeggs 2009-11-05 06:24:47 UTC
Once it's finished building, can you update to http://koji.fedoraproject.org/koji/buildinfo?buildID=139823 (kernel-2.6.31.5-122.fc12) and retry.

Thanks!

Comment 12 Thomas J. Baker 2009-11-05 13:55:25 UTC
I had the same problem after updating this morning. X would crash for me at login with this backtrace:

(II) NOUVEAU(0): Modeline "720x400"x70.1   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e582c]
1: /usr/bin/Xorg (mieqEnqueue+0x1b7) [0x80e5157]
2: /usr/bin/Xorg (xf86PostMotionEventP+0xd4) [0x80bf8e4]
3: /usr/lib/xorg/modules/input/evdev_drv.so (0x552000+0x3172) [0x555172]
4: /usr/lib/xorg/modules/input/evdev_drv.so (0x552000+0x3466) [0x555466]
5: /usr/bin/Xorg (0x8047000+0x6b230) [0x80b2230]
6: /usr/bin/Xorg (0x8047000+0x11ec54) [0x8165c54]
7: (vdso) (__kernel_sigreturn+0x0) [0x729400]
8: (vdso) (__kernel_vsyscall+0x2) [0x729416]
9: /lib/libc.so.6 (ioctl+0x19) [0x26de39]
10: /usr/lib/libdrm.so.2 (drmIoctl+0x2e) [0x5dd288e]
11: /usr/lib/libdrm.so.2 (drmCommandWrite+0x3c) [0x5dd2c1c]
12: /usr/lib/libdrm_nouveau.so.1 (0x405000+0x29fa) [0x4079fa]
13: /usr/lib/libdrm_nouveau.so.1 (nouveau_bo_map_range+0xf8) [0x407c48]
14: /usr/lib/libdrm_nouveau.so.1 (nouveau_bo_map+0x34) [0x407d14]
15: /usr/lib/xorg/modules/drivers/nouveau_drv.so (0x618000+0x989b) [0x62189b]
16: /usr/lib/xorg/modules/drivers/nouveau_drv.so (0x618000+0x9a15) [0x621a15]
17: /usr/lib/xorg/modules/libexa.so (0x53e000+0x3633) [0x541633]
18: /usr/lib/xorg/modules/libexa.so (0x53e000+0x649d) [0x54449d]
19: /usr/lib/xorg/modules/libexa.so (0x53e000+0x37e3) [0x5417e3]
20: /usr/lib/xorg/modules/libexa.so (0x53e000+0xf7bf) [0x54d7bf]
21: /usr/lib/xorg/modules/libexa.so (0x53e000+0xd11e) [0x54b11e]
22: /usr/bin/Xorg (0x8047000+0xd49d7) [0x811b9d7]
23: /usr/bin/Xorg (CompositePicture+0x290) [0x810eec0]
24: /usr/bin/Xorg (0x8047000+0xce0f5) [0x81150f5]
25: /usr/bin/Xorg (0x8047000+0xcac84) [0x8111c84]
26: /usr/bin/Xorg (0x8047000+0x27187) [0x806e187]
27: /usr/bin/Xorg (0x8047000+0x1b875) [0x8062875]
28: /lib/libc.so.6 (__libc_start_main+0xe6) [0x1b2bb6]
29: /usr/bin/Xorg (0x8047000+0x1b461) [0x8062461]


The new kernel (122) fixes it.

Comment 13 Michal Schmidt 2009-11-05 14:28:03 UTC
Ben,

the tag f12-final now contains kernel-2.6.31.5-117.fc12 which has this bug. What will be the impact if F12 is released with this kernel? Will this bug affect all nvidia cards or only a few models? Will the bug be triggered by the default settings on the final live CDs? Is 'nomodeset' a safe workaround?

Comment 14 Martin Naď 2009-11-05 15:02:44 UTC
kernel -122 works

Comment 15 Michal Schmidt 2009-11-06 13:28:46 UTC
I can see -122 got into today's Rawhide. Excellent. Thanks.

Comment 16 josh 2009-11-22 02:39:15 UTC
I'm seeing this message with F12 (just upgraded to F11) kernel-2.6.31.5-127.fc12.x86_64, although X is running.  However, whenever I click the KDE menu the system hangs completely for a minute or two before picking up as though nothing had happened...

Comment 17 josh 2009-11-22 02:40:00 UTC
(In reply to comment #16)
> I'm seeing this message with F12 (just upgraded to F11)
> kernel-2.6.31.5-127.fc12.x86_64, although X is running.  However, whenever I
> click the KDE menu the system hangs completely for a minute or two before
> picking up as though nothing had happened...  

Oops - forgot to mention I'm using the NVIDIA proprietary driver from rpmfusion-nonfree-updates-testing, and not nouveau...

Comment 18 Michal Schmidt 2009-11-22 10:21:32 UTC
"Need Real Name",
The symptoms you describe are caused by a known bug in the Nvidia proprietary driver when used with current Xorg. Fedora developers cannot fix bugs in proprietary drivers.


Note You need to log in before you can comment on or make changes to this bug.