Bug 53295 - laptop harddrive constantly running
laptop harddrive constantly running
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-06 00:33 EDT by Bobby Brinkley
Modified: 2007-04-18 12:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 13:26:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bobby Brinkley 2001-09-06 00:33:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.3) Gecko/20010801

Description of problem:
My Presario 1655's harddrive constantly runs (constant disk access and
thrashing)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot
2.log in
3.whala
	

Actual Results:  harddrive constantly thrashes

Expected Results:  Disk access when needed and not constantly.

Additional info:
Comment 1 Arjan van de Ven 2001-09-06 06:50:02 EDT
Is this different compared to previous releases ?
Comment 2 sahag 2001-09-06 11:26:45 EDT
i have the same problem.
this is not different from the previous release but i think you should do
something.
my laptop has 256Mb memory and linux never let's it spin down.
even if you don't do anything on a computer linux accesses the harddrive
periodically for a very short time.
i think you should do something about this, because it's a big pain using linux
on a latop
Comment 3 Bobby Brinkley 2001-09-10 12:11:10 EDT
I didn't recall having the same problem in 7.1, but not really sure.
Comment 4 Nicole Leahy 2003-01-23 16:27:05 EST
I am having this problem as well.  I am running RetHap 7.2 on a Dell Inspiron 
7500.  I didn't have this problem when the machine was running 6.2
Comment 5 Ali-Reza Anghaie 2003-04-04 07:47:14 EST
I think it would help if y'all would check a few things: 
 
- Check the cron tables for ~all~ the users on the system. "tail /var/log/cron" and see 
who/what are running them. 
 
- If you're a KDE user, turn off the .kde/Autostart/ Autorun entry which will poll often and show 
HD access. If you're GNOME, consider turning off the equivalent thing that looks for new 
media... I don't recall the 'magic' thing or whatever it is. 
 
- Some X savers will hit disk constantly while they're running, not sure why. Turn the saver to 
a blank screen, and this goes away. 
 
I've seen this behavior on some IBM laptops since 7.2 even after turning off everything. 
Literally dropping out of X (to prevent font rereading, etc.), chkconfig off most everything... 
pretty raw system. Then eventually I noticed the same thing happened under Windows.. same 
timing and such. 
 
If you're drive is constantly thrashing it sounds like swapping for no reason or silly polling done 
my Autorun or equiv. And it's probably not 'thrashing', just annoying.  ;-) 
 
If you really think there is an individual compontent causing this then consider doing the same 
thing I did the first time around (after disabling the above): 
 
- Drop out of X completely, shut it down. If that stopped the disk access, start comparing ps 
-ef differences. Kill one process at a time, etc. 
- Drink beer. 
 
Cheers, -Ali 
Comment 6 Alan Cox 2003-06-05 13:26:58 EDT
Also the "noatime" mount option is appropriate for laptops

Not a bug however

Note You need to log in before you can comment on or make changes to this bug.