Bug 533021 - broken ejabberd in f12 due to erlang update
Summary: broken ejabberd in f12 due to erlang update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ejabberd
Version: 12
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-04 18:03 UTC by Krzysztof Urbaniak
Modified: 2010-01-27 09:09 UTC (History)
3 users (show)

Fixed In Version: ejabberd-2.1.0-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-27 09:09:19 UTC


Attachments (Terms of Use)

Description Krzysztof Urbaniak 2009-11-04 18:03:01 UTC
Description of problem:
ejabberd is broken in rawhide (f12) because of erlang update.
It won't start on i686 and x86_64, without reporting any error.
Here is the thread on ejabberd.im: http://www.ejabberd.im/node/3486
This patch should be applied to the ejabberd source: https://support.process-one.net/browse/EJAB-919

Version-Release number of selected component (if applicable):
ejabberd-2.0.5-9.fc12.x86_64
erlang-R13B-01.2.fc12.x86_64

How reproducible:
Install ejabberd, service ejabberd start, wait few seconds and check if proces beam(.smp) is listening on ports like 5222, 5269: `netstat -tapun|grep beam`

Steps to Reproduce:
1.
2.
3.
  
Actual results:
beam is only listening on 40000


Expected results:
beam should listen on 5222 (c2s) and 5269 (s2s)

Additional info:

Comment 1 Peter Lemenkov 2009-11-04 18:14:26 UTC
Thanks for the info. I'll take care of this issue.

Comment 2 Peter Lemenkov 2009-11-05 13:42:55 UTC
Done. Krzysztof, please, grab these packages and test them:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1789733

Comment 3 Krzysztof Urbaniak 2009-11-05 20:23:13 UTC
RPM from koji works for me now on x86_64 and i686.
Thanks for very quick reacion. ;)

Comment 4 Bug Zapper 2009-11-16 15:05:51 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Fedora Update System 2009-12-10 20:31:50 UTC
ejabberd-2.1.0-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ejabberd-2.1.0-2.fc12

Comment 6 Fedora Update System 2009-12-10 20:31:55 UTC
ejabberd-2.1.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ejabberd-2.1.0-2.fc11

Comment 7 Fedora Update System 2009-12-11 18:21:04 UTC
ejabberd-2.1.0-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ejabberd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13078

Comment 8 Fedora Update System 2009-12-11 18:38:27 UTC
ejabberd-2.1.0-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ejabberd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13145

Comment 9 Fedora Update System 2009-12-23 21:31:57 UTC
ejabberd-2.1.0-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.