Bug 533046 - Old Publican projects fail with missing Makefile.common
Old Publican projects fail with missing Makefile.common
Status: CLOSED WONTFIX
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-04 14:26 EST by Nathanael Noblet
Modified: 2010-11-23 23:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 07:30:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathanael Noblet 2009-11-04 14:26:12 EST
Description of problem:
A user with current publican projects using the F11 0.44 will receive a file not found error when running make X in their projects once updated to F12

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cd /path/to/publican044/project
2. make help
3.
  
Actual results:
Makefile:20: /usr/share/publican/make/Makefile.common: No such file or directory
make: *** No rule to make target `/usr/share/publican/make/Makefile.common'.  Stop.


Expected results:
Well my reason for submitting this is to suggest that a Makefile.common file be created that outputs directions for updating publican files for all commands that *could* be run via make. Just to point users to the publican old2new commands.

Additional info:
Comment 1 Ruediger Landmann 2009-11-16 07:30:48 EST
Thanks Nathanael -- it's an excellent suggestion and an elegant fix. If only we had thought of it while version 1.0 was in development!

As things stand, we hope that the current version is reasonably stable, so by the time that this fix makes it into a release, it will almost certainly be redundant because anyone who was going to be bitten by this would already have been bitten.

Sorry that you took the fall, and hopefully, there weren't too many other people in the same boat as you. Unless we hear of more cases, however, I'm closing this as WONTFIX, for now at least.

Cheers

Ruediger
Comment 2 Bug Zapper 2009-11-16 10:06:32 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.