Bug 533050 - abrtd brought my system to a standstill by flooding syslog
abrtd brought my system to a standstill by flooding syslog
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-11-04 15:02 EST by Lennart Poettering
Modified: 2015-02-01 17:49 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-29 08:19:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2009-11-04 15:02:29 EST
abrtd for some reason started to flood my syslog with these two messages:

Nov  3 23:55:19 omega abrtd: Hmm, stray warn_client: 'RunAction(): CPluginManager::GetAction():Action plugin: 'KerneloopsScanner' is not registered.'
Nov  3 23:55:19 omega abrtd: Hmm, stray update_client: 'Execution of 'KerneloopsScanner' was not successful: CPluginManager::GetAction():Action plugin: 'KerneloopsScanner' is not registered.'

This caused /var/run to run full, at which point not much worked anymore, big disaster ensued.

This must not happen. abrtd *must* employ rate limiting for everything it logs!
Comment 1 Lennart Poettering 2009-11-04 15:11:12 EST
/var of course ran full (via /var/log), not /var/run. Sorry for the confusion.
Comment 2 Denys Vlasenko 2009-11-05 06:37:40 EST
You did not install KerneloopsScanner abrt plugin, but have it enabled in /etc/abrt/abrt.conf

How did you install abrt? "yum install abrt-<what exactly>"?

(This is the result of over-abundance of abrt rpms...)
Comment 3 Jiri Moskovcak 2009-11-05 07:44:57 EST
ABRt shouldn't try to run the action plugins blindly and it should wanr about this failure only once, because if plugin isn't loaded than it will never succeed unless the plugin is installed and daemon restarted ...

And I don't agree that this a problem with too many rpms, it's a problem with badly designed config files.
Comment 4 Lennart Poettering 2009-11-05 11:35:50 EST
(In reply to comment #2)
> You did not install KerneloopsScanner abrt plugin, but have it enabled in
> /etc/abrt/abrt.conf

I installed abrt quite some time ago and since then only upgraded. I haven't added the config files or anything.

> How did you install abrt? "yum install abrt-<what exactly>"?

No idea, that was months ago. And back then I didn't get syslog flooding.
Comment 5 Lennart Poettering 2009-11-05 11:36:11 EST
s/added/edited
Comment 6 Lennart Poettering 2009-11-05 11:37:34 EST
(In reply to comment #3)
> ABRt shouldn't try to run the action plugins blindly and it should wanr about
> this failure only once, because if plugin isn't loaded than it will never
> succeed unless the plugin is installed and daemon restarted ...

That is true.

> And I don't agree that this a problem with too many rpms, it's a problem with
> badly designed config files.  

That is true as well.

However, what is important is that abrtd also rate limits is syslog spew like any other sensible software.
Comment 7 Denys Vlasenko 2010-01-29 08:19:55 EST
Closing the bug. Please reopen if you can reproduce this with abrt properly installed, that is: when abrt does not have configuration settings which require non-installed plugins.

Note You need to log in before you can comment on or make changes to this bug.