Bug 533058 - gtkdoc-mkhtml fails when building a package
Summary: gtkdoc-mkhtml fails when building a package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sgml-common
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-04 20:43 UTC by D. Marlin
Modified: 2009-11-12 00:59 UTC (History)
2 users (show)

Fixed In Version: 0.6.3-27.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-11 11:24:03 UTC


Attachments (Terms of Use)

Description D. Marlin 2009-11-04 20:43:09 UTC
Description of problem:

When building an RPM package that includes gtk-doc html files, gtkdoc-mkhtml fails.  The command and error from the log are:

  mkdir ./html
  cd ./html && gtkdoc-mkhtml mimedir ../mimedir-docs.sgml
  /usr/bin/openjade:/etc/sgml/catalog:6:8:E: cannot open "/etc/sgml/openjade-1.3.2-34.fc11.soc" (No such file or directory)
    :

Version-Release number of selected component (if applicable):

  Fedora release 11.92 (Rawhide)
  sgml-common-0.6.3-30.fc12.noarch
  openjade-1.3.2-35.fc12.i686
  gtk-doc-1.11-5.fc12.noarch


How reproducible:

  Always


Steps to Reproduce:
1.  See command in description above
  

Actual results:

  Error messages displayed:
/usr/bin/openjade:/etc/sgml/catalog:6:8:E: cannot open "/etc/sgml/openjade-1.3.2-34.fc11.soc" (No such file or directory)


Expected results:

  No "cannot open" error messages.


Additional info:

If I remove the following line from /etc/sgml/catalog the build completes as expected:

  -CATALOG "/etc/sgml/openjade-1.3.2-34.fc11.soc"

I'm not sure if this line should be updated or removed, but it appears to be incorrect for the F12 Beta release.

Comment 1 Ondrej Vasik 2009-11-04 21:38:38 UTC
It seems something went wrong in openjade catalog registrations - most probably it has nothing to do with sgml-common package, but more with openjade - as the .soc catalog file is registered by that package. Latest version should be openjade-1.3.2-35.fc12, so probably something went wrong during update (it looks like the catalog file of the old openjade package was not unregistered properly) - reassigning to openjade (just formal, as it is another my package) and will check what's wrong there.

Comment 2 Ondrej Vasik 2009-11-11 11:24:03 UTC
You were right, culprit was in sgml-common - patch for correct removal entries from /etc/sgml/catalog was accidently removed by https://www.redhat.com/archives/fedora-extras-commits/2007-November/msg05885.html in November 2007 during MergeReview changes. Fixed in RAWHIDE build sgml-common-0.6.3-31.fc13 , will do updates soon for existing Fedoras to prevent upgrade/update issues. Thanks for report.

Comment 3 Fedora Update System 2009-11-11 11:42:14 UTC
sgml-common-0.6.3-31.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/sgml-common-0.6.3-31.fc12

Comment 4 Fedora Update System 2009-11-11 12:14:15 UTC
sgml-common-0.6.3-28.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/sgml-common-0.6.3-28.fc11

Comment 5 Fedora Update System 2009-11-11 12:15:08 UTC
sgml-common-0.6.3-27.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/sgml-common-0.6.3-27.fc10

Comment 6 Fedora Update System 2009-11-12 00:51:49 UTC
sgml-common-0.6.3-28.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2009-11-12 00:57:50 UTC
sgml-common-0.6.3-31.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2009-11-12 00:59:40 UTC
sgml-common-0.6.3-27.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.