Bug 53311 - XFree3.x fails to load with Trio 64 3D
XFree3.x fails to load with Trio 64 3D
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-06 09:39 EDT by jpranevich
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 12:48:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg (7.21 KB, text/plain)
2001-09-06 09:42 EDT, jpranevich
no flags Details
Contents of /proc/pci (1.51 KB, text/plain)
2001-09-06 09:43 EDT, jpranevich
no flags Details

  None (edit)
Description jpranevich 2001-09-06 09:39:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
During the install, RedHat detects my card and everything perfectly 
(except for defaulting to 800x600 -- ugh) and shows the "click here if you 
see this" box, but subsequent boots fail with an error message that it 
can't connect to XFS. (However that seems to be running fine.) If I run 
Xconfigurator with --perferxf4 it works fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat Roswell using default settings. (Including correct video 
card settings.)
2. Reboot system and start X (either by starting runlevel 5 or startx)
3. 	

Actual Results:  It doesn't work, but it does seem to try to initialize 
video.

Expected Results:  It should work. :)

Additional info:

This server is an IBM PC300PL/Pentium II Model 689247U with an S3 Trio3D 
AGP video card with 4 megs of SGRAM. (See also 
http://www4.pc.ibm.com/us/products.nsf/$wwwPartNumLookup/_689247U)

I will append dmesg, /proc/pci, and a log of startx failing with XFree3.x.
Comment 1 jpranevich 2001-09-06 09:42:15 EDT
Created attachment 31076 [details]
Dmesg
Comment 2 jpranevich 2001-09-06 09:43:33 EDT
Created attachment 31077 [details]
Contents of /proc/pci
Comment 3 Kyle Gonzales 2001-09-06 12:48:25 EDT
I had a very similar error with an S3 Virge DX/GX card.  Xconfigurator would
detect the card and the monitor, and the chosen settings would test fine. 
However, X would not start, the error being "Cannot find default font 'fixed'".
 If I run Xconfigurator with --preferxf4, then X will start without a problem.

It is always reproducable, and the steps to reproduce are the same as above.  If
you need further info, please let me know.

Comment 4 Mike A. Harris 2001-09-06 16:07:08 EDT
Bug in 4.1.0, fixed in Rawhide, please update.

Note You need to log in before you can comment on or make changes to this bug.