This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 533139 - missing qt4-config int the system-> preferences menu
missing qt4-config int the system-> preferences menu
Status: CLOSED DUPLICATE of bug 244879
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-05 05:41 EST by chedi toueiti
Modified: 2009-11-05 08:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 08:48:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description chedi toueiti 2009-11-05 05:41:31 EST
Description of problem:
I'm just missing the qtconfig-qt4 in the system->preferences panel (but I have the qt3 one).

Version-Release number of selected component (if applicable):
qt-x11-4.5.3-7.fc12.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I think I'm missing something here, why there is two enrties from the same file ??

[chedi@localhost Desktop]$ rpm -ql qt-x11 | grep desktop
/usr/share/applications/qt4-qtconfig.desktop
/usr/share/applications/qt4-qtconfig.desktop

[chedi@localhost Desktop]$ rpm -ql qt-x11 | grep desktop | xargs ls -li
58304 -rw-r--r--. 1 root root 234 2009-10-29 17:30 /usr/share/applications/qt4-qtconfig.desktop
58304 -rw-r--r--. 1 root root 234 2009-10-29 17:30 /usr/share/applications/qt4-qtconfig.desktop


[chedi@localhost Desktop]$ rpm -ql qt-x11 | grep desktop | xargs cat

[Desktop Entry]
Name=Qt4 Config 
Comment=Configure Qt4 behavior, styles, fonts
Exec=qtconfig-qt4
Icon=qt4-logo
Terminal=false
Encoding=UTF-8
Type=Application
Categories=Qt;Settings;
NoDisplay=true
X-Desktop-File-Install-Version=0.15

[Desktop Entry]
Name=Qt4 Config 
Comment=Configure Qt4 behavior, styles, fonts
Exec=qtconfig-qt4
Icon=qt4-logo
Terminal=false
Encoding=UTF-8
Type=Application
Categories=Qt;Settings;
NoDisplay=true
X-Desktop-File-Install-Version=0.15
Comment 1 Kevin Kofler 2009-11-05 05:59:39 EST
Well, this is intentionally hidden from the menu. But I don't really see why we're hiding it, can't we just drop that NoDisplay patch? Our users expect to find qtconfig-qt4 in the menu!
Comment 2 Rex Dieter 2009-11-05 08:47:13 EST
2 copies = 2 copies of qt-x11 (ie, you have a multilib'd x86_64/i386 install)?

Otherwise, a dup bug #244879

Maybe we could consider going back to simply not installing it (qt-config) by default, and show the menu when/if it is installed.

The primary reason it's hidden, is that most users don't want or need to see it.  It's setting are largely superceded by the environment you're running in (esp if in KDE).
Comment 3 Rex Dieter 2009-11-05 08:48:31 EST
Anyway, not going to change via bugzilla, discussion needs to happen on-list (or in irc) or something.

*** This bug has been marked as a duplicate of bug 244879 ***

Note You need to log in before you can comment on or make changes to this bug.