Bug 53316 - 'Unclosed %if' error trying to rebuild qt-2.3.1 (-3 and -4) from SRPM
'Unclosed %if' error trying to rebuild qt-2.3.1 (-3 and -4) from SRPM
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-06 11:07 EDT by Tim Wunder
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 09:54:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Wunder 2001-09-06 11:07:35 EDT
When I execute rpm --rebuild qt-2.3.1-3.src.rpm, I get an Unclosed %if error. This happens with both qt-2.3.1-3.src.rpm downloaded from 
the kde mirror site and qt-2.3.1-4.src.rpm, downloaded from the rawhide SRPM ftp site
Comment 1 Bernhard Rosenkraenzer 2001-09-09 17:13:45 EDT
Translator messup. %endif was removed after a %description tag by the program 
that injects translations into the RPMs.

This will be fixed in 8.0, simply ignore it for now, it's just a harmless 
warning.
Comment 2 Tim Wunder 2001-09-27 09:54:08 EDT
Hmmm. "simply ignore it for now, it's just a harmless warning." OK, how do I ignore it? I execute "rpm --rebuild qt-2.3.1-3.src.rpm" and the rebuild 
FAILS with the error message "Unclosed %if error". How do I go about "ignoring" that? Is there an rpm --rebuild --"ignore that error you're going to 
get" switch?
Or, are you telling me that I can't use rpm to compile qt and should download the source?
Comment 3 Bernhard Rosenkraenzer 2001-09-27 12:32:59 EDT
You can't ignore it because you're using an ancient version of rpm.
The current rpm just displays the warning and goes on.

Either update rpm, or add the %endif after the "%description Xt" section 
manually. (The build system keeps removing it when it injects translations, 
that's why it's broken in the first place).

The fixed package is waiting for the compiler update in the 8.0 environment.

Note You need to log in before you can comment on or make changes to this bug.