Bug 533239 - metacity calls illegal functions from sigterm handler
Summary: metacity calls illegal functions from sigterm handler
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: metacity   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F12Blocker, F12FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2009-11-05 18:53 UTC by Ray Strode [halfline]
Modified: 2013-01-10 05:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-06 00:54:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 600864 None None None Never

Description Ray Strode [halfline] 2009-11-05 18:53:28 UTC
Just noticed metacity using 99% cpu.  I investigated it a bit with mccann and
it's because metacity is calling meta_finalize from a sigterm handler.

This is a big no-no.  There is a set of maybe 10 - 15 functions that are legal
to call from a sigterm handler.

Comment 1 Adam Williamson 2009-11-05 22:36:54 UTC
Ray provided a patched metacity for testing:

http://koji.fedoraproject.org/koji/buildinfo?buildID=139997

a bug in that build has been discovered, and Ray is now working on another update:

<Oxf13> halfline: and metacity is spiking the CPU
<halfline> sweet
<halfline> i can log in, but things definitely aren't right
<halfline> investigating
<Oxf13> halfline: ok, the second time I got logged in
<Oxf13> but it's still spiking the CPU
<halfline> Oxf13: yea, patch needs to be reworked
<halfline> Oxf13: g_io_channel isn't firing
<Oxf13> ok.  glad I tested 9:
<halfline> must be a leaked fd somewhere
<halfline> rather than tackling that bug where ever it is, instead i'm going to just not rely on hup and do an explicit write call

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Adam Williamson 2009-11-05 23:26:21 UTC
Improved fixed metacity is at:

http://koji.fedoraproject.org/koji/buildinfo?buildID=140020

Jesse is testing.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Adam Williamson 2009-11-06 00:54:11 UTC
the fixed build was tagged.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.