Bug 53327 - spurius mail to root when /var/cache/man/X11R6/cat? missing
Summary: spurius mail to root when /var/cache/man/X11R6/cat? missing
Status: CLOSED DUPLICATE of bug 47784
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-06 19:10 UTC by Bowe Strickland
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-06 19:10:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bowe Strickland 2001-09-06 19:10:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Because glob in /etc/cron.daily/tmpwatch misses, bash passes ? into
tmpwatch, and tmpwatch generates error
message for nonexistant /var/cache/man/X11R6/cat\?.  

received one/day in root's mail:

>> Date: Thu, 6 Sep 2001 15:20:31 -0400
>> From: root <root@localhost.localdomain>
>> To: root@server1.example.com
>> Subject: tmpwatch error
>> 
>> /etc/cron.daily/tmpwatch:
>> 
>> error: lstat() of directory /var/cache/man/X11R6/cat? failed: No such
file or directory


suggested fix:

[ -d /var/cache/man/X11R6 ] && ... (or something like)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. up2date updated man rpm to man-1.5i2-0.7x, removing directories and
causing problems 
2.
3.
	

Actual Results:  /etc/cron.daily/tmpwatch began generating spurius mail

Additional info:

Comment 1 Preston Brown 2001-09-06 19:24:44 UTC

*** This bug has been marked as a duplicate of 47784 ***


Note You need to log in before you can comment on or make changes to this bug.