Bug 53329 - i810 XVideo limited to 720x576
i810 XVideo limited to 720x576
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-09-06 15:50 EDT by Philip Pokorny
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-19 07:00:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to allow i810 to use 1440x1080 XVideo images (1.33 KB, patch)
2001-09-06 16:02 EDT, Jim Wright
no flags Details | Diff

  None (edit)
Description Philip Pokorny 2001-09-06 15:50:42 EDT
Description of Problem:
The i810 XVideo driver is limited to images 720x576 pixels in size.  The
hardware is capable of 1440 x (unlimited) resolution.  However it needs to
be configured appropriately.

Version-Release number of selected component (if applicable):
4.1 of XFree86

How Reproducible:
Attempt to allocate an image larger than 720 pixels wide.  The image will
be truncated to 720 pixels.

Steps to Reproduce:

Actual Results:
Garbage image or segfault

Expected Results:
Accelrated image display.

Additional Information:
I have a patch that fixes this.  Will attach it momentarily.  Have
submitted same to xfree86-list
Comment 1 Jim Wright 2001-09-06 16:02:47 EDT
Created attachment 31134 [details]
Patch to allow i810 to use 1440x1080 XVideo images
Comment 2 Mike A. Harris 2002-03-19 07:00:09 EST
I've sent the patch upstream for inclusion in the trunk, as well as for
comment from someone more familiar with the hardware.  Once I hear back
from upstream that it looks ok, I'll apply it to our packaging.

Thanks for the patch.
Comment 3 Mike A. Harris 2002-05-17 20:27:46 EDT
Applied to my internal development tree now, and will appear in future
erratum for Red Hat Linux 7.3, and also in future rawhide releases.

Fix is in 4.2.0-9.12
Comment 4 Mark J. Cox 2003-06-25 11:52:25 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.