Bug 533306 - libvirt crashes unless run by root with virsh restore / save
libvirt crashes unless run by root with virsh restore / save
Status: CLOSED DUPLICATE of bug 534143
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-05 19:34 EST by David
Modified: 2010-03-16 13:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 13:28:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David 2009-11-05 19:34:24 EST
Description of problem:
In the new Fedora 12 beta, I encountered a problem where the default /etc/libvirt/qemu.conf file that came with the system was not configured correctly. I had to uncomment the lines "user = "root"" and "group = "root"" in order to get everything working correctly. These lines came commented and are commented in previous versions of fedora, but they worked that way.




Version-Release number of selected component (if applicable):
libvirt version 0.7.1, fedora version 12 beta

How reproducible:
all the time.


Steps to Reproduce:
1. Virsh restore some VM
2. Virsh save some vm (you will get an error message here)
If you go to /var/log/libvirt/qemu/VM.log, you'll see that the VM had a permission problem.
3.
  
Actual results:
virsh save fails and libvirtd needs to be restarted.

Expected results:
No permission problem and that the VM properly saves itse.f


Additional info:
Comment 1 David 2009-11-10 13:20:27 EST
I'm new to the bug reporting thing, so my title was not very great. I changed the title to be more descriptive of the actual problem. I hope this helps
Comment 2 David 2009-11-10 13:28:59 EST

*** This bug has been marked as a duplicate of bug 534143 ***

Note You need to log in before you can comment on or make changes to this bug.