Bug 53332 - AIO: Winnt_cdrom: setfilepointer() for F: failed: 0x83
AIO: Winnt_cdrom: setfilepointer() for F: failed: 0x83
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-06 16:26 EDT by felicia.ives
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 14:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description felicia.ives 2001-09-06 16:26:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
installed Win NI 4.0 sp6 (host) and VMWare 2.0 on a latitude w/6 gig hdd, 
128Mb RAM.  When instlalling redhat 7.1 as a guest on a virtual/real 
partition (doesn't matter if booting text or gui or expert), 7.1 hangs 
(locks up) at "running sbin/loader".  The CDROM is labled F:.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install win NT/2K
2. install VMWare
3. create a guest profile for a linux on a virtual disk or "raw partition"
4. power on guest
5. hit pf2 to change the boot to cdrom, save and exit setup
6. when linux boot menu appears select gui, text or expert.
	

Actual Results:  In the log for VMWare guest os, there are messages:
ATAPI_CDROM: MODE SENSE (ALMOST) COMPLETELY EMULATED
ATAPI_CDROM: MODE SENSE PACKET 0x5a 0x0 0x2a 0x0 0x0 0x0 x0x 0x0 0x18 0x0 
0x0
ATAPI_CDROM: UNKNOWN COMMAND 0x51
AIO THREAD 0x3b PANIC
WINNT_CDROM: SETFILEPOINTER() FOR F: failed 0X83
AIO_WAIT: IN PANIC
AIO_WAIT: IN PANIC
AIO_WAIT: IN PANIC
MSG_POST ERROR MSG.LOG.PANIC


Expected Results:  redhat linux 7.1 should have started the installation 
setup

Additional info:

check out http://www.linuxquestions.org/questions/history/6164 or 
search for "VMWare install OR installation) linux sbin loader(hang OR 
hangs OR boot)" on google.com you will see an number of people who have 
the same problem.  one suggested that you had to put cdrom.sychronous = 
true in the vmware profile for the linux guest and download kernel 2.4.3-
12.  however how do you install the new kernel and or fixes without the 
7.1 kernal installed anywhere?
Comment 1 Michael K. Johnson 2001-09-06 16:43:06 EDT
Feel free to report this bug to vmware or microsoft.  This is not a
bug in Red Hat Linux.
Comment 2 felicia.ives 2001-09-07 10:31:39 EDT
This problem has already been to VMWare.  If you had done your homework instead you would have known that. I have given you what symptoms 
you should need and given you the last messages in the trace log.  I am a former level 1, 2 and 3 OS support  tech and  I am not pleased with your 
response. This is what I found under http://www.linuxquestions.org/questions/history/4639, maybe you should study it before making 
pronouncements that there is no problem, especially when this is happening on more than just one laptop and not only under VMWare.  Also look 
at http://www.linuxquestions.org/questions/showthread.php?s=bd95cf3b5b74d8607a3501fd75a84452&threadid=1058&highlight=sbin%2Floader  
and at 
http://www.linuxquestions.org/questions/showthread.php?s=bd95cf3b5b74d8607a3501fd75a84452&threadid=727&highlight=sbin%2Floader.  I 
should not have to do your research.

eddied
Newbie

Registered: Jul 2001
Location: 
Distribution: 
Posts: 2
 Just received an answer from VMWare on this one 
Lockups During the Install of Red Hat Linux 7.1 in a virtual machine. 
SYMPTOM: Client tries to load Red Hat 7.1 in a virtual machine, after 
running other virtual machines successfully. Red Hat 7.1 locks up the 
virtual machine during the install at "running sbin/loader" and will 
continue no further. 
PROBLEM: VMware has identified and confirmed that there is a bug 
in Linux Kernel 2.4.2 (which is used for the install of RH 7.1) which 
causes lockups due to timing problems. VMware(TM) Workstation virtual 
machines are affected by this bug. This occurs on both Windows and 
Linux host machines. Extensive testing and work have been done on 
this problem, and the kernel bug has been confirmed with Linux kernel 
developers. 
SOLUTION: We've empirically determined that the lock-up occurs much 
less frequently with a setting change in the virtual machine 
configuration file. As a convenience to our customers, we have 
confirmed that the following workaround will allow you to get RH 7.1 
installed. 
PLEASE FOLLOW ALL STEPS in these instructions; the configuration 
change SHOULD NOT be left in your virtual machine's configuration 
permanently, or other problems may occur. Here is the workaround: 
1. Before starting the RH 7.1 installer, add the following line 
anywhere in your virtual machine's configuration (CFG or VMX) file: 
cdrom.synchronous=TRUE 
2. Start the RH install, confirm that you get past the lockup point, 
and install RH the rest of the way. 
3. After RH 7.1 is installed correctly, and networking configured, 
download and install the latest Linux kernel (2.4.3-12) from Red 
Hat Update, or from Red Hat's web site: 
http://www.redhat.com 
4. Power off the VM 
5. FIND AND REMOVE the following line from your virtual machine's 
configuration (CFG or VMX): 
cdrom.synchronous=TRUE 
6. Save changes to the configuration file, and reboot your VM with 
the new kernel. Red hat 7.1 should work fine within the virtual 
machine now.
Comment 3 Arjan van de Ven 2001-09-07 10:36:49 EDT
VMWare never ever contacted nor informed us about any problems; nor have 
"confirmed" this with us or the kernel developers on the linux kernel mailinglist.
As this problem only occurs with the VMWare virtual machine and not with real
hardware, pointing the finger to the emulation is quite reasonable in my opinion.
Comment 4 felicia.ives 2001-09-07 13:04:15 EDT
Here is an example of the problem without installing as a VMWare host.

ho_chi_minh
  Newbie

  Registered: Jul 2001
  Location: 
  Distribution: 
  Posts: 2
                            

                            

                         Similar problem here with installation of Redhat v7.1 

                         I am booting from floppy or from cdrom. Tried all options 
                         from GUI install, expert install, text install. In each case 
                         the hardware detection lines fly by the screen until the 
                         process comes to 

                         /sbin/loader 

                         This is where is stalls. In the GUI case this simply ends 
                         up as a blue screen. 

                         After some time, the process turns to anaconda, and reports 
                         an error 11 back, shuts down the various loaded system 
                         components. 

                         I can imagine this to be a hardware problem. I've tried to 
                         install 7.1 on an AMD Thunderbird with ASUS board and 
                         512 M RAM 

                         I also tried an older ASUS board with Pentium 200. Same 
                         result. 

                         No clue what is causing this RedHat blue screen of death... 
                         but it looks like a RedHat install bug, or a video card related 
                         bug perhaps. I am using an ATI all-in-wonder, the other system 
                         is a Matrox Millenium video card. 

                         Well, hope this info can be of use to someone and help resolve 
                         it. If I find out more, I'll post it. 

                         Ho Chi Minh
Comment 5 Arjan van de Ven 2001-09-07 13:08:09 EDT
That's a totally different bug where this guy's IDE CDROM drive doesn't support
UDMA properly; there is a (long) list of cdrom drives that pretent to support
UDMA but don't; we added a "ide=nodma" commandline option to work around the
drives that were not yet on the blacklist.
Comment 6 felicia.ives 2001-09-07 13:56:41 EDT
You don't seem to understand I am getting the 'running/sbin/loader' problem and when I check with the VMWare log (see above) that is what I find.
I have already check with VMWare support my self and did not find any problem reported with them.  VMWare panicked because of the hang 
condition.
Comment 7 Alan Cox 2003-06-06 14:27:09 EDT
vmware is not something we support

Note You need to log in before you can comment on or make changes to this bug.