This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 533409 - issues with passwordless user (live cd)
issues with passwordless user (live cd)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-11-06 11:46 EST by Matthias Clasen
Modified: 2015-01-14 18:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-09 11:05:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2009-11-06 11:46:27 EST
The first time I select live user from the user list on a just-booted live cd, I get a cancel and a logout button (no password entry, correctly)

I choose cancel.

The second time I select live user, I just get a cancel button (still no password entry, correctly)

I choose cancel - what else ?!

The third time I select live user, I see the cancel button for a split second, but this time gdm proceeds to start the session.
Comment 1 Ray Strode [halfline] 2009-11-06 14:14:46 EST
I've reproduced and addressed this issue in

2.28.1-24.fc12

marking modified
Comment 2 Ray Strode [halfline] 2009-11-06 14:15:21 EST
Adding to blocker list so it gets on the appropriate radars.
Comment 3 Adam Williamson 2009-11-06 14:36:05 EST
as stated on IRC, my opinion is this is not sufficiently serious to be a blocker and not even serious enough to touch gdm code to fix, at this late stage. clicking 'cancel' on the only available user on the live CD is a pretty weird thing to do, and the impact of the bug is not terrible.

I won't protest if the decision goes the other way, though.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Matthias Clasen 2009-11-06 15:05:03 EST
First impressions are important. The login screen of the live cd is something a new users sees even before the installer.
Comment 5 Ray Strode [halfline] 2009-11-06 15:34:49 EST
There seemed to be a loose consensus (modulo adamw) on irc at the time that this should get tagged and go in if we need to respin for other reasons, but not force a respin on its own.
Comment 6 Ray Strode [halfline] 2009-11-06 15:57:30 EST
For reference, the change in question is:


@@ -968,7 +968,7 @@ gdm_greeter_login_window_start_session_when_ready 
                  * so they can pick language/session.  Will need to refactor
                  * a bit so we can share code with timed login.
                  */
-                if (!login_window->priv->timed_login_enabled) {
+                if (strcmp (service_name, "gdm-autologin") != 0) {
 
                         g_debug ("GdmGreeterLoginWindow: Okay, we'll start the session anyway,"
                                  "because the user isn't ever going to get an opportunity to"
Comment 7 Adam Williamson 2009-11-06 16:42:18 EST
mclasen: but they don't see this bug unless they pick a user account and then hit cancel, which is a rather unusual operation.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Adam Williamson 2009-11-07 23:03:21 EST
I think this got tagged, didn't it?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Ray Strode [halfline] 2009-11-09 11:05:44 EST
yup

Note You need to log in before you can comment on or make changes to this bug.