Bug 53341 - RFE: Raise exception in kickstart if selected --fstype is not available [Installer hangs when fstype is specified for partitions]
RFE: Raise exception in kickstart if selected --fstype is not available [Inst...
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-06 18:46 EDT by Kyle Gonzales
Modified: 2008-01-17 12:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyle Gonzales 2001-09-06 18:46:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802

Description of problem:
When using this kickstart config:

### Start working ks.cfg snippet ###

zerombr yes
clearpart --linux
part /boot --size 32
part swap --size 256
part / --size 256 --grow
install

### End working ks.cfg snippett ###

the install proceeds without error.

However, when using this config:

### Start failing ks.cfg snippett ###

zerombr yes
clearpart --linux
part /boot --size 32 --fstype ext3
part swap --size 256
part / --size 256 --fstype ext3 --grow
install
### End failing ks.cfg snippett ###

The installer says it formatted the partitions, then hangs on a blank
screen.  A message comes up on the F3 terminal, saying "IOError 28 occured
getting
ftp://porkchop.redhat.com/mnt/test/roswell2-i386/i386/RedHat/base/hdlist2:
No space left on device".

The installer stops here.  As far as I can tell from the 7.2 manuals, this
kickstart syntax is correct.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. In ks.cfg, specify "--fstype ext3" for the non-swap partitions.
2. Install using that ks.cfg file.
3. Wait for failure.
	

Actual Results:  Installer hangs after formatting the partitions.

Expected Results:  Installer should continue normally.

Additional info:
Comment 1 Matt Wilson 2001-09-06 18:51:21 EDT
what is the full ks.cfg
Comment 2 Matt Wilson 2001-09-06 18:58:53 EDT
I can't reproduce this.  Where is the machine?
Comment 3 Kyle Gonzales 2001-09-07 10:14:36 EDT
The machine is one of the old NuLogix boxes we have in house.  Celeron 333 w/
128 meg of memory.  I have it sitting in IS if you want to take a look at it.

Also, the swap partition DOES appear to get created, just not the data partitions.

The full ks.cfg file (minus the %post section which it doesn't get to):

### Start ks.cfg file ###

lang en_US

langsupport --default en_US

network --bootproto dhcp

url --url ftp://porkchop.redhat.com/mnt/test/roswell2-i386/i386

keyboard "us"

zerombr yes
clearpart --linux
part /boot --size 32 --fstype ext3
part swap --size 256 --fstype swap
part / --size 256 --fstype ext3 --grow
install

mouse

timezone America/New_York

xconfig --defaultdesktop=GNOME --resolution 1024x768 --depth 16

rootpw --iscrypted $1$b21xJQ10$dSFr20C.7aANskLX/ME3V1

auth --useshadow

bootloader --location=mbr

%packages
@ GNOME 
@ Authoring and Publishing
@ Software Development
@ Games and Entertainment
@ Graphics and Image Manipulation
@ Sound and Multimedia Support
@ Printing Support
@ Windows Compatibility / Interoperability
@ Messaging and Web Tools
@ Network Support
@ Utilities
compat-glibc
compat-libs
compat-libstdc++
openssh-server
sash

### End ks.cfg file ###

If you REALLY want the %post section (which is really really long) let me know.
Comment 4 Kyle Gonzales 2001-09-07 10:30:42 EDT
ack!  That ks.cfg file was my changed file, when I was typing to diagnose the
problem.  I tried both these lines:

part swap --size 256 --fstype swap

and

part swap --size 256

And got the same results regardless.  Both times swap was created, and the data
partitions were not.

What other info do you need?
Comment 5 Matt Wilson 2001-09-07 15:27:50 EDT
boot disk mismatched caused ext3 to be unavailable.  kickstart set up the
partition anyway, but didn't mount it as the kernel has no mount support for
ext3.  This caused the url fetching code to not have a place to put hdstage2 and
we hung there.
Comment 6 Michael Fulbright 2002-03-26 12:44:29 EST
Deferring to future release.
Comment 7 Red Hat Bugzilla 2006-02-21 13:48:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.