Bug 533504 - last screen state is visible on wakeup despite screensaver password protection
last screen state is visible on wakeup despite screensaver password protection
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-06 16:56 EST by Jeffrey Warren
Modified: 2015-01-14 18:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 22:28:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Warren 2009-11-06 16:56:16 EST
Description of problem:
When the machine wakes from sleep, the last visible screen flashes for a moment (1/4 second) before the user is locked out and  prompted for a password. For security reasons this should be suppressed - a user approaching a sleeping machine should not be able to get a glimpse of what was on the screen - even for a moment.

Version-Release number of selected component (if applicable):


How reproducible:

intermittent but at least daily

Steps to Reproduce:
1. let the machine go to sleep (typically by closing the laptop lid)
2. wake it
3. 
  
Actual results:


Expected results:


Additional info:
Comment 1 Bug Zapper 2009-11-16 10:15:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tim Taiwanese Liim 2010-05-01 00:38:25 EDT
Jeffrey,
Do you still see this issue?  Now that g-ss has changed quite a bit
since Comment #0 it may have been fixed.  Now it worked fine on my
several F12 (no glimpse of last visible screen).
Comment 3 James 2010-05-01 01:51:08 EDT
I still see this with gnome-screensaver-2.28.3-1.fc12.x86_64.
Comment 4 Tim Taiwanese Liim 2010-05-03 18:43:01 EDT
James,
Thanks for confirming the issue is still present.  I tried the
procedure in Comment #0
  1. let the machine go to sleep, by closing the laptop lid
  2. wake it
and I saw a blank screen for a moment, then the lock screen; no glimpse
of screen prior to sleep.  I am also using gss-2.28.3-1.fc12.x86_64,
on Sony VAIO VGN-FE890, Intel 945GM graphic chip.

Do you see this issue consistently?  Is the system under high CPU
load?  Does the power source (AC/battery) make any difference?  Do the
different themes (Blank screen, Cosmos, etc) make any difference?  Any
idea how I may be able to reproduce this issue?  Thanks.
Comment 5 James 2010-05-28 15:13:25 EDT
Tim,

One way I know of getting a *brief* gimpse of the underlying desktop is to switch VT to a text console, wait enough time for the screensaver, then switch back to X. It is at that point that the display locks, as if I had immediately pressed Ctrl+Alt+L --- so although the timeout's been registered, the screensaver hasn't started. However, this might be a red-herring and a different problem.

I'm not sure yet what circumstances lead to the worse one, where the underlying desktop persists (but its image is largely frozen). I'll try doing more sleep-testing...
Comment 6 Bug Zapper 2010-11-04 02:44:56 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2010-12-03 22:28:45 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.