Bug 533562 - Please upgrade ExtUtils::Manifest to at least 1.52
Please upgrade ExtUtils::Manifest to at least 1.52
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: 532928
  Show dependency treegraph
 
Reported: 2009-11-07 05:42 EST by Alex Lancaster
Modified: 2009-12-04 07:50 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 07:50:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2009-11-07 05:42:35 EST
Currently this blocks an upgrade of the perl-bioperl package which requires:

ExtUtils::Manifest >= 1.52

Without it, perl-bioperl 1.6.1 won't build, get this:

Checking prerequisites...
 - ERROR: ExtUtils::Manifest (1.51_01) is installed, but we need version >= 1.52

According to the upstream developers it is necessary to be strict about this version.  My original query:

http://bioperl.org/pipermail/bioperl-l/2009-November/031529.html

and the response:

http://bioperl.org/pipermail/bioperl-l/2009-November/031538.html
Comment 1 Marcela Mašláňová 2009-11-09 11:39:42 EST
I hope you don't need it for F-12. I'm okay with rawhide update.
Comment 2 Alex Lancaster 2009-11-09 15:44:21 EST
(In reply to comment #1)
> I hope you don't need it for F-12. I'm okay with rawhide update.  

Umm, yes, I do.  Otherwise I won't be able to update bioperl for a whole release cycle, which means users won't be able to use the new bioperl in a stable Fedora release (which is a bug fix release) for at least 6 more months.  

I knew this would be an issue, so I brought it up with upstream and you can see their response:

http://bioperl.org/pipermail/bioperl-l/2009-November/031538.html

Suggested workarounds welcome.
Comment 3 Marcela Mašláňová 2009-11-10 03:06:10 EST
The build is failing on missing CPAN package. As far as I know you shouldn't need CPAN, because it's used for auto install of missing packages. Maybe I'm wrong and you're simply missing requirement.
I don't have problem with updating release of ExtUtils::Manifest, but I'm against creating zero update for perl. I'm usually fixing more bugs in an update so it take few weeks. In F-13 we are working on packaging perl-5.10.1, so the update there also take a few weeks.

You can try as a workaround edit Makefile.PL and see whether the higher version is really needed.
Comment 4 Alex Lancaster 2009-11-10 03:27:38 EST
(In reply to comment #3)
> The build is failing on missing CPAN package. As far as I know you shouldn't
> need CPAN, because it's used for auto install of missing packages. Maybe I'm
> wrong and you're simply missing requirement.
> I don't have problem with updating release of ExtUtils::Manifest, but I'm
> against creating zero update for perl. I'm usually fixing more bugs in an
> update so it take few weeks. In F-13 we are working on packaging perl-5.10.1,
> so the update there also take a few weeks.
> 
> You can try as a workaround edit Makefile.PL and see whether the higher version
> is really needed.  

It is, as explained by upstream:

http://bioperl.org/pipermail/bioperl-l/2009-November/031538.html

but I may be able to workaround that because we probably don't need to create a MANIFEST during the package build.
Comment 5 Chris Weyl 2009-11-10 11:02:15 EST
Looks like ExtUtils::Manifest is at 1.56 in 5.10.1...  I agree with Alex; we're supposed to be going to 5.10.1 in rawhide, F-11/F-12 Perl are essentially the same right now, and we haven't even released F-12 yet.

We should be able to backport from 5.10.1 and leave this kicking around in updates-testing for a while...  in F-11 at least.
Comment 6 Bug Zapper 2009-11-16 10:16:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Marcela Mašláňová 2009-12-04 07:50:17 EST
In rawhide perl 5.10.1 contains ExtUtils::Manifest 1.56.

Note You need to log in before you can comment on or make changes to this bug.