Bug 533613 - no drm on Radeon Xpress 200M
no drm on Radeon Xpress 200M
Status: CLOSED DUPLICATE of bug 532308
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-07 15:27 EST by Juergen Gier
Modified: 2009-12-02 12:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 12:56:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log with KMS enabled (default) (59.93 KB, text/plain)
2009-11-07 15:27 EST, Juergen Gier
no flags Details
Xorg.0.log with nomodeset kernel parm (49.03 KB, text/plain)
2009-11-07 15:28 EST, Juergen Gier
no flags Details
xorg.conf (928 bytes, text/plain)
2009-11-07 15:29 EST, Juergen Gier
no flags Details
/var/log/messages from lockup w/ nomodeset (43.84 KB, text/plain)
2009-11-07 15:37 EST, Juergen Gier
no flags Details

  None (edit)
Description Juergen Gier 2009-11-07 15:27:41 EST
Created attachment 367968 [details]
Xorg.0.log with KMS enabled (default)

Description of problem:
I can't get HW 3D acceleration. With KMS enabled X starts and everything works, except for drm. I do get software rendering through mesa. Xorg.0.log says
"(EE) RADEON(0): [drm] Could not create vertex/indirect buffers list"

With kernel parm nomodeset I can boot into runlevel 3, but X locks up at start, and I can only power-cycle the notebook.

I had this problem with the xorg-x11-server packages from stable (1.6.4-0.1), so I upgraded from updates-testing, but this didn't resolve it.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.2-14.fc11.i586
xorg-x11-server-[Xorg|common]-1.6.4-0.3.fc11.i586
kernel-2.6.30.9-96.fc11.i586

How reproducible:
always

Steps to Reproduce:
1.boot
2.
3.
  
Actual results:
with KMS: no drm
without KMS: X lockup

Expected results:
3D HW accel works.

Additional info:
Comment 1 Juergen Gier 2009-11-07 15:28:35 EST
Created attachment 367969 [details]
Xorg.0.log with nomodeset kernel parm
Comment 2 Juergen Gier 2009-11-07 15:29:37 EST
Created attachment 367970 [details]
xorg.conf
Comment 3 Juergen Gier 2009-11-07 15:37:14 EST
Created attachment 367971 [details]
/var/log/messages from lockup w/ nomodeset
Comment 4 Juergen Gier 2009-11-23 12:00:45 EST
With Fedora 12 the X lockup is gone. That is, I can now start X *and* get acceleration, but I still need nomodeset.
Comment 5 Matěj Cepl 2009-12-02 12:56:42 EST
Duplicate of either bug 532308 or any other from http://is.gd/5afoA bugs.

*** This bug has been marked as a duplicate of bug 532308 ***

Note You need to log in before you can comment on or make changes to this bug.